Triangular Sums
Triangular Sums
时间限制:3000 ms | 内存限制:65535 KB
难度:2
- 描述
-
The nth Triangular number, T(n) = 1 + … + n, is the sum of the first n integers. It is the number of points in a triangular array with n points on side. For example T(4):
X
X X
X X X
X X X X
Write a program to compute the weighted sum of triangular numbers:
W(n) =
SUM[k = 1…n; k * T(k + 1)]
- 输入
- The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.
Each dataset consists of a single line of input containing a single integer n, (1 ≤ n ≤300), which is the number of points on a side of the triangle. - 输出
- For each dataset, output on a single line the dataset number (1 through N), a blank, the value of n for the dataset, a blank, and the weighted sum ,W(n), of triangular numbers for n.
- 样例输入
-
4 3 4 5 10
- 样例输出
-
1 3 45 2 4 105 3 5 210 4 10 2145
- 来源
- Greater New York 2006
- 上传者
01.
#include<stdio.h>
02.
int
WN(
int
n)
03.
{
04.
int
i,sum=0;
05.
for
(i=1;i<n+1;i++)
06.
{
07.
sum+=i*((i+1)*(i+2))/2;
08.
}
09.
return
sum;
10.
}
11.
int
main()
12.
{
13.
int
i,N,n,a[1000];
14.
scanf
(
"%d"
,&N);
15.
for
(i=0;i<N;i++)
16.
{
17.
scanf
(
"%d"
,&a[i]);
18.
}
19.
for
(i=0;i<N;i++)
20.
{
21.
printf
(
"%d %d %d\n"
,i+1,a[i],WN(a[i]));
22.
}
23.
24.
return
0;
25.
}