24 Point game

24 Point game

时间限制: 3000 ms  |  内存限制: 65535 KB
难度: 5
描述

There is a game which is called 24 Point game.

In this game , you will be given some numbers. Your task is to find an expression which have all the given numbers and the value of the expression should be 24 .The expression mustn't have any other operator except plus,minus,multiply,divide and the brackets. 

e.g. If the numbers you are given is "3 3 8 8", you can give "8/(3-8/3)" as an answer. All the numbers should be used and the bracktes can be nested. 

Your task in this problem is only to judge whether the given numbers can be used to find a expression whose value is the given number。

输入
The input has multicases and each case contains one line
The first line of the input is an non-negative integer C(C<=100),which indicates the number of the cases.
Each line has some integers,the first integer M(0<=M<=5) is the total number of the given numbers to consist the expression,the second integers N(0<=N<=100) is the number which the value of the expression should be.
Then,the followed M integer is the given numbers. All the given numbers is non-negative and less than 100
输出
For each test-cases,output "Yes" if there is an expression which fit all the demands,otherwise output "No" instead.
样例输入
2
4 24 3 3 8 8
3 24 8 3 3
样例输出
Yes
No
来源
经典改编

//一开始只有起始的几个数 ,然后通过回溯每次取任意两个数进行加、减、乘、除、被减、被除6种操作,然后把结果放到集合中,并且在集合中删去之前操作的两个数,直到集合中只有一个数了,那么比较一下是不是24(注意因为过程中有除法的存在,这里就涉及到一个精度问题,多次运算过后可能会出现24.000001或者23.999999这种情况,所以要注意,不能单纯的(int)一下

#include <bits/stdc++.h>

using namespace std;
bool vis[15];
double tar,arr[15];
int n;
double judge(double x,double y,int k)
{
    switch(k)
    {
        case 0: return x + y;
        case 1: return x - y;
        case 2: return x * y;
        case 3: return x / y;
        case 4: return y - x;
        case 5: return y / x;
    }
}
bool dfs(int num,int p)
{
    if(num == 1 && fabs(arr[p] - tar)< 1e-6)
        return true;
    double temp_1,temp_2;
    for(int i=0;i<n;i++)
    {
        if(!vis[i])
            for(int j=i+1;j<n;j++)
        {
            if(!vis[j])
            {
                temp_1 = arr[i];
                temp_2 = arr[j];
                for(int k=0;k<6;k++)
                {
                    if(k == 3&&arr[j] == 0||k == 5&&arr[i] == 0)
                        continue;
                    arr[j] = judge(arr[i],arr[j],k);
                    vis[i] = true;
                    if(dfs(num-1,j))
                        return true;
                    vis[i] = false;
                    arr[i] = temp_1;
                    arr[j] = temp_2;
                }
            }
        }
    }
    return false;
}
int main()
{
    int Case;
    cin>>Case;
    while(Case--)
    {
       cin>>n>>tar;
       for(int i=0;i<n;i++)
       {
           cin>>arr[i];
       }
       for(int i=0;i<15;i++)
        vis[i] = false;
        if(dfs(n,n-1))
            cout<<"Yes"<<endl;
        else cout<<"No"<<endl;
    }
    return 0;
}


posted @ 2017-03-06 18:10  legolas007  阅读(38)  评论(0编辑  收藏  举报