HDU 1711 Number Sequence

Number Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 25039    Accepted Submission(s): 10599


Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 

Sample Input
  
2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1
 

Sample Output
  
6 -1
 

Source
 
//KMP
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>

const int N = 1000005;

int n, m, a[N], b[N], next[N];

void get_next(){
    int p = 0;
    for (int i = 2; i <= m; i++) {
        while (p > 0 && b[p+1] != b[i])
            p = next[p];
        if (b[p+1] == b[i])
            p++;
        next[i] = p;
    }
}
int KMP(){
    get_next();
    int p = 0;
    for (int i = 1; i <= n; i++) {
        while (p > 0 && b[p+1] != a[i])
            p = next[p];
        if (b[p+1] == a[i])
            p++;
        if (p == m) {
            return i - m + 1;
        }
    }
    return -1;
}

int main () {
    int cas;
    scanf("%d", &cas);
    while (cas--) {
    scanf("%d%d", &n, &m);
    for (int i = 1; i <= n; i++)
        scanf("%d", &a[i]);
    for (int i = 1; i <= m; i++)
        scanf("%d", &b[i]);
        printf("%d\n", KMP());
    }
    return 0;
}



posted @ 2017-03-16 21:32  legolas007  阅读(16)  评论(0编辑  收藏  举报