HDU 3448 Bag Problem

Bag Problem

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 32768/131072 K (Java/Others)
Total Submission(s): 1796 Accepted Submission(s): 499

Problem Description
0/1 bag problem should sound familiar to everybody. Every earth man knows it well. Here is a mutant: given the capacity of a bag, that is to say, the number of goods the bag can carry (has nothing to do with the volume of the goods), and the weight it can carry. Given the weight of all goods, write a program that can output, under the limit in the above statements, the highest weight.

Input
Input will consist of multiple test cases The first line will contain two integers n (n<=40) and m, indicating the number of goods and the weight it can carry. Then follows a number k, indicating the number of goods, k <=40. Then k line follows, indicating the weight of each goods The parameters that haven’t been mentioned specifically fall into the range of 1 to 1000000000.

Output
For each test case, you should output a single number indicating the highest weight that can be put in the bag.

Sample Input
5 100
8
8 64 17 23 91 32 17 12
5 10
3
99 99 99

Sample Output
99
0

题意:给k个数,问最多取n个,所取的数的和不大于m的最大的和;
题解:dfs+01dp

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;
const int maxn = 110;
typedef int ll;
ll ans = 0;
ll a[maxn];
ll n, m;
int k;
void dfs(int pos, int num, int  sum)
{
    ans = max(ans, sum);
    if (pos == k + 1)return;
    dfs(pos + 1, num, sum);
    if (sum + a[pos] <= m && num + 1 <= n)
        dfs(pos + 1, num + 1, sum + a[pos]);
}
int main()
{
    while (~scanf("%d%d",&n,&m))
    {
        cin >> k;
        for (int i = 1;i <= k;i++)
        cin>>a[i];
        sort(a + 1, a + 1 + k);
        int sum = 0;
        for (int i = k;i >= k - n + 1; i--)
            sum += a[i];
        if (sum <= m) { 
        cout << sum << endl;
        continue; }
        ans = 0;
        dfs(1, 0, 0);
        cout << ans << endl;
        }
    return 0;
}
posted @ 2017-04-01 17:34  legolas007  阅读(14)  评论(0编辑  收藏  举报