第十二周作业

第十二周作业

这个作业属于那个课程 C语言程序设计II
这个作业要求在哪里 https://edu.cnblogs.com/campus/zswxy/software-engineering-class1-2018/homework/2825
我在这个课程的目标是 学习指针的进阶
这个作业在哪个具体方面帮助我实现目标 上课听老师讲解,做题目,与同学交流
参考文献 C语言程序设计II

6-1 计算最长的字符串长度

本题要求实现一个函数,用于计算有n个元素的指针数组s中最长的字符串的长度。

函数接口定义:

int max_len( char *s[], int n );

其中n个字符串存储在s[]中,函数max_len应返回其中最长字符串的长度。

裁判测试程序样例:

#include <stdio.h>
#include <string.h>
#include <stdlib.h>

#define MAXN 10
#define MAXS 20

int max_len( char *s[], int n );

int main()
{
    int i, n;
    char *string[MAXN] = {NULL};

    scanf("%d", &n);
    for(i = 0; i < n; i++) {
        string[i] = (char *)malloc(sizeof(char)*MAXS);
        scanf("%s", string[i]);
    }
    printf("%d\n", max_len(string, n));

    return 0;
}

/* 你的代码将被嵌在这里 */

输入样例:

4
blue
yellow
red
green

输出样例:

6

实验代码

int max_len( char *s[], int n ){
int max=0;
int i,j;

for(i=0;i<n;i++){
    if(strlen(s[max])<strlen(s[i])){
        max=i;  
    }
}   
return strlen(s[max]);
} 

编程截图

6-2 统计专业人数

本题要求实现一个函数,统计学生学号链表中专业为计算机的学生人数。链表结点定义如下:

struct ListNode {
    char code[8];
    struct ListNode *next;
};

这里学生的学号共7位数字,其中第2、3位是专业编号。计算机专业的编号为02。

函数接口定义:

int countcs( struct ListNode *head );

其中head是用户传入的学生学号链表的头指针;函数countcs统计并返回head链表中专业为计算机的学生人数。

裁判测试程序样例:

#include <stdio.h>
#include <stdlib.h>
#include <string.h>

struct ListNode {
    char code[8];
    struct ListNode *next;
};

struct ListNode *createlist(); /*裁判实现,细节不表*/
int countcs( struct ListNode *head );

int main()
{
    struct ListNode  *head;

    head = createlist();
    printf("%d\n", countcs(head));
	
    return 0;
}

/* 你的代码将被嵌在这里 */

输入样例:

1021202
2022310
8102134
1030912
3110203
4021205
#

输出样例:

3

实验代码

int countcs(struct ListNode*head)

{

int num=0;

struct ListNode *p=head;

while(p!=NULL){

  if (p->code[1]=='0'&&p->code[2]=='2'){

      num++;

   }

  p=p->next;

  }

return num;

}

编程截图

6-3 删除单链表偶数节点

本题要求实现两个函数,分别将读入的数据存储为单链表、将链表中偶数值的结点删除。链表结点定义如下:

struct ListNode {
    int data;
    struct ListNode *next;
};

函数接口定义:

struct ListNode *createlist();
struct ListNode *deleteeven( struct ListNode *head );

函数createlist从标准输入读入一系列正整数,按照读入顺序建立单链表。当读到−1时表示输入结束,函数应返回指向单链表头结点的指针。

函数deleteeven将单链表head中偶数值的结点删除,返回结果链表的头指针。

裁判测试程序样例:

#include <stdio.h>
#include <stdlib.h>

struct ListNode {
    int data;
    struct ListNode *next;
};

struct ListNode *createlist();
struct ListNode *deleteeven( struct ListNode *head );
void printlist( struct ListNode *head )
{
     struct ListNode *p = head;
     while (p) {
           printf("%d ", p->data);
           p = p->next;
     }
     printf("\n");
}

int main()
{
    struct ListNode *head;

    head = createlist();
    head = deleteeven(head);
    printlist(head);

    return 0;
}

/* 你的代码将被嵌在这里 */

输入样例:

1 2 2 3 4 5 6 7 -1

输出样例:

1 3 5 7 

实验代码

struct ListNode *createlist()
{
    int x;
    struct ListNode *head,*ptr,*p;
    head=(struct ListNode*)malloc(sizeof(struct ListNode));
    head->next=NULL;
    ptr=head;
    while(1)
    {
        p=(struct ListNode*)malloc(sizeof(struct ListNode));
        p->next=NULL;
        scanf("%d",&x);
        if(x==-1)
            break;
        p->data=x;
        p->next=NULL;
        ptr->next=p;
        ptr=p;
    }
     return head;
}

struct ListNode *deleteeven( struct ListNode *head )
{
    struct ListNode *p1,*p2;
    int flag;
    p1=head;
    p2=p1->next;
    while(p1->next)
    {
        flag=0;
        if(p2->data%2==0)
        {
            p1->next=p2->next;
            p2=p2->next;
            flag=1;
        }
        if(flag==0)
        {
            p1=p1->next;
            p2=p1->next;
        }
    }
        return head->next;
}

编程截图

学习进度

周/日期 这周花的时间 代码行数 学到的知识点简介 目前比较困惑的
3/3-3/9 6h 40 文件的处理以及对于数据的处理 对于指针的不熟悉
3/10-3/15 7h 45 文件的处理以及对于数据的处理 二维数组的运用
3/16-3/22 8h 130 选择排序及其他二维数组利用 知识点中的冒泡排序
3/23-3/29 8h 70 字符串的运用 冒泡排序与字符串结合运用
3/30-4/5 7h 140 指针的运用 指针结合具体题目不很懂
4/6-4/12 8h 150 掌握指针、数组、地址之间的用法 之间的相互联系不懂
4/13-4/18 8h 156 灵活运用字符串 做题目不会,很多地方不懂
4/19-4/26 9h 173 结构的运用 不是很会,借鉴了同学的
5/6-5/10 6h 60 递归函数的使用 后面的大题,不会,不太懂
5/12-5/17 6h 146 指针的进阶 不太能熟练运用
posted @ 2019-05-17 17:22  外滩海浪  阅读(216)  评论(1编辑  收藏  举报