H - Frosh Week

Description

During Frosh Week, students play various fun games to get to know each other and compete against other teams. In one such game, all the frosh on a team stand in a line, and are then asked to arrange themselves according to some criterion, such as their height, their birth date, or their student number. This rearrangement of the line must be accomplished only by successively swapping pairs of consecutive students. The team that finishes fastest wins. Thus, in order to win, you would like to minimize the number of swaps required.
 

Input

The first line of input contains one positive integer n, the number of students on the team, which will be no more than one million. The following n lines each contain one integer, the student number of each student on the team. No student number will appear more than once. 
 

Output

Output a line containing the minimum number of swaps required to arrange the students in increasing order by student number. 
 

Sample Input

3
3
1
2
 

Sample Output

2
 
AC代码:
#include<iostream>//归并排序
#include<cstdio>
#include<algorithm>
#include<cstring>
# define M 1000010
using namespace std;
long long int cnt;
int A[M],T[M];
int y,m;
void merge_sort(int*A,int x,int y,int *T)
{
  if(y-x>1)
  {
   int m=x+(y-x)/2;//划分
   int p=x,q=m,i=x;
   merge_sort(A,x,m,T);//递归求解
   merge_sort(A,m,y,T);//递归求解
   while(p<m||q<y)
   {
     if(q>=y||(p<m&&A[p]<=A[q]) )T[i++]=A[p++];//从左半数组复制到临时空间
	 else
	 {
		 T[i++]=A[q++];//从右半数组复制到临时空间
		 cnt+=m-p;
	 }
   }
	 for(i=x;i<y;i++)
		 A[i]=T[i];//从辅助空间复制回A数组
  }
}

int main()
{
	int n;

	while(scanf("%d",&n)!=EOF)
	{
	    cnt=0;
		memset(A,0,sizeof(A));
		memset(T,0,sizeof(T));
		int i=0;
		while(n--)
		{
	scanf("%d",&A[i++]);
		}
    merge_sort(A,0,i,T);
		printf("%lld\n",cnt);

	}

return 0;

}
 
分析:问题的实质是一个逆序对,用归并排序的方法解决
分治三步法:1.划分问题:把序列分成元素个数尽量相等的两部分
               2.递归求解:把两半元素分别求解
               3.合并问题:把两个有序表合并成一个
 
 
 
 
 
 
posted @ 2016-07-22 19:40  踮起脚望天  阅读(399)  评论(0编辑  收藏  举报