PAT-甲级-1005 Spell It Right C++
Given a non-negative integer , your task is to compute the sum of all the digits of , and output every digit of the sum in English.
Input Specification:
Each input file contains one test case. Each case occupies one line which contains an ().
Output Specification:
For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.
Sample Input:
12345
Sample Output:
one five
题意:
题目意思是计算c=a+b,但是要按照英文输出c,50则输出five zero。
分析:
水题。
代码:
//
// Created by yaodong on 2023/7/11.
//
#include "iostream"
int main() {
std::string n;
std::cin >> n;
int len = n.length();
int sum = 0;
for (int i = 0; i < len; ++i) {
sum += n[i] - '0';
}
std::string number[] = {"zero", "one", "two", "three", "four",
"five", "six", "seven", "eight", "nine"};
std::string sumString = std::to_string(sum);
for (int i = 0; i < sumString.length(); ++i) {
if(i == 0)
printf("%s", number[sumString[i] - '0'].c_str());
else
printf(" %s", number[sumString[i] - '0'].c_str());
}
}
分类:
PAT甲级
【推荐】国内首个AI IDE,深度理解中文开发场景,立即下载体验Trae
【推荐】编程新体验,更懂你的AI,立即体验豆包MarsCode编程助手
【推荐】抖音旗下AI助手豆包,你的智能百科全书,全免费不限次数
【推荐】轻量又高性能的 SSH 工具 IShell:AI 加持,快人一步
· 分享一个免费、快速、无限量使用的满血 DeepSeek R1 模型,支持深度思考和联网搜索!
· 基于 Docker 搭建 FRP 内网穿透开源项目(很简单哒)
· ollama系列1:轻松3步本地部署deepseek,普通电脑可用
· 按钮权限的设计及实现
· 【杂谈】分布式事务——高大上的无用知识?