PAT-basic-1020 月饼 java

一、题目


月饼是中国人在中秋佳节时吃的一种传统食品,不同地区有许多不同风味的月饼。现给定所有种类月饼的库存量、总售价、以及市场的最大需求量,请你计算可以获得的最大收益是多少。

注意:销售时允许取出一部分库存。样例给出的情形是这样的:假如我们有 3 种月饼,其库存量分别为 18、15、10 万吨,总售价分别为 75、72、45 亿元。如果市场的最大需求量只有 20 万吨,那么我们最大收益策略应该是卖出全部 15 万吨第 2 种月饼、以及 5 万吨第 3 种月饼,获得 72 + 45/2 = 94.5(亿元)。

输入格式:

每个输入包含一个测试用例。每个测试用例先给出一个不超过 1000 的正整数  表示月饼的种类数、以及不超过 500(以万吨为单位)的正整数  表示市场最大需求量。随后一行给出  个正数表示每种月饼的库存量(以万吨为单位);最后一行给出  个正数表示每种月饼的总售价(以亿元为单位)。数字间以空格分隔。

输出格式:

对每组测试用例,在一行中输出最大收益,以亿元为单位并精确到小数点后 2 位。

输入样例:

3 20
18 15 10
75 72 45

输出样例:

94.50

二、解析


贪心策略,比较好选,单位价格最大就行。有坑:月饼总售价是正数,不是正整数。。。

三、代码


import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.util.ArrayList;
import java.util.Collections;
import java.util.Comparator;
import java.util.Scanner;
public class Main {
    public static void main(String[] args) throws IOException {
        ArrayList<MoonCake> list = new ArrayList<>();
        BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
        String s[] = br.readLine().split("\\s+");
        int n = Integer.parseInt(s[0]);
        int d = Integer.parseInt(s[1]);
        String str1[] = br.readLine().split("\\s+");
        String str2[] = br.readLine().split("\\s+");
        for (int i = 0; i < n; i++) {
            double store = Double.parseDouble(str1[i]);
            double sellPrice = Double.parseDouble(str2[i]);
            MoonCake mc = new MoonCake(store, sellPrice);
            list.add(mc);
        }

        Collections.sort(list, new Comparator<MoonCake>(){
            @Override
            public int compare(MoonCake o1, MoonCake o2) {
                if(o2.unit - o1.unit > 0) return 1;
                else return -1;
            }
        });

        int tag = 0;
        double sum = 0;
        while(d != 0 && (tag<list.size())){
            MoonCake mc = list.get(tag++);
            if(d <= mc.getStore()){
                sum += d * mc.unit;
                d = 0;
            }else{
                sum += mc.sellPrice;
                d -= mc.getStore();
            }
        }
        System.out.printf("%.2f", sum);
    }
    static class MoonCake{
        private double store;
        private double sellPrice;
        public double unit;

        public MoonCake(double store, double sellPrice) {
            this.store = store;
            this.sellPrice = sellPrice;
            this.unit = sellPrice*1.0/store;
        }

        public double getStore() {
            return store;
        }

        public void setStore(double store) {
            this.store = store;
        }

        public double getSellPrice() {
            return sellPrice;
        }

        public void setSellPrice(double sellPrice) {
            this.sellPrice = sellPrice;
        }
    }
}

 

posted @ 2023-02-18 16:43  正明小佐  阅读(36)  评论(0编辑  收藏  举报