HDU 1509 Windows Message Queue

Windows Message Queue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6113    Accepted Submission(s): 2496


Problem Description
Message queue is the basic fundamental of windows system. For each process, the system maintains a message queue. If something happens to this process, such as mouse click, text change, the system will add a message to the queue. Meanwhile, the process will do a loop for getting message from the queue according to the priority value if it is not empty. Note that the less priority value means the higher priority. In this problem, you are asked to simulate the message queue for putting messages to and getting message from the message queue.
 

 

Input
There's only one test case in the input. Each line is a command, "GET" or "PUT", which means getting message or putting message. If the command is "PUT", there're one string means the message name and two integer means the parameter and priority followed by. There will be at most 60000 command. Note that one message can appear twice or more and if two messages have the same priority, the one comes first will be processed first.(i.e., FIFO for the same priority.) Process to the end-of-file.
 

 

Output
For each "GET" command, output the command getting from the message queue with the name and parameter in one line. If there's no message in the queue, output "EMPTY QUEUE!". There's no output for "PUT" command.
 

 

Sample Input
GET
PUT msg1 10 5
PUT msg2 10 4
GET
GET
GET
 
Sample Output
EMPTY QUEUE!
msg2 10
msg1 10
EMPTY QUEUE!
 
Author
ZHOU, Ran
 
Source

 这是一道优先队列的题目,题目的意思是PUT时输入一条消息 msg1代表名称,10代表参数,5代表优先级,输入的消息按优先级排序(优先队列,自定义排序规则)

遇到GET时输出优先级最高的消息,没有消息时输出EMPTY QUEUE!

#include<iostream>
#include<cstring>
#include<queue>
#include<cstdio>
#include<algorithm>
using namespace std;
struct node 
{
    char name[20];
    int num,grade,tmp;
}m;
bool operator<(struct node p,struct node q)
{
    if(p.grade!=q.grade)
       return p.grade>q.grade;
    return p.num > q.num;
}//自定义排序规则,优先级不等时按优先级从大到小排,相等时按先后顺序排
int main()
{
    char str[20];
    int num=0;
    priority_queue<node>q;
    while(~scanf("\n%s",str))
    {
        if(!strcmp(str,"PUT"))
        {
            cin >> m.name >> m.tmp >> m.grade;
            m.num = ++num;
            q.push(m);
        }
        if(!strcmp(str,"GET"))
        {
            if(q.empty())
              printf("EMPTY QUEUE!\n");
            else 
            {
                printf("%s %d\n",q.top().name,q.top().tmp);
                q.pop();
            }
        }
    }
    return 0;
} 

 

posted on 2017-03-21 20:23  九月旧约  阅读(176)  评论(0编辑  收藏  举报

导航