UVaOJ 10340 - All in All

All in All

Input: standard input

Output: standard output

Time Limit: 2 seconds

Memory Limit: 32 MB

You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string.

Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s.

Input Specification

The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace. Input is terminated by EOF.

Output Specification

For each test case output, if s is a subsequence of t.

Sample Input

sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter

Sample Output

Yes
No
Yes
No

本题需要注意:
数组s和t要开的足够大,而且要放在main()外面;
其他地方还是较为简单。
#include <stdio.h>
#include <stdlib.h>
#include <string.h>

char s[102400],t[102400];

int main()
{

    int len_s,len_t;
    int i,j,count,temp;
    while(scanf("%s",s)!=EOF)
    {
        scanf("%s",t);
        len_s = strlen(s);
        len_t = strlen(t);
        count=0;
        temp = 0;
        for(i=0; i<len_s; i++)
        {
            for(j=temp; j<len_t; j++)
            {
                if(s[i] == t[j])
                {
                    temp = j+1;
                    count++;
                    break;
                }
            }
        }
        if(count == len_s)
            printf("Yes\n");
        else
            printf("No\n");
    }

    return 0;
}



   

posted @ 2014-10-17 21:54  Popco  阅读(156)  评论(0编辑  收藏  举报