UVA - 1644 Prime Gap

The sequence of n - 1 consecutive composite numbers (positive integers that are not prime and not equal to 1) lying between two successive prime numbers p and p + n is called a prime gapof length n . For example, $ \langle$24, 25, 26, 27, 28$ \rangle$ between 23 and 29 is a prime gap of length 6.

Your mission is to write a program to calculate, for a given positive integer k , the length of the prime gap that contains k . For convenience, the length is considered 0 in case no prime gap contains k .

Input 

The input is a sequence of lines each of which contains a single positive integer. Each positive integer is greater than 1 and less than or equal to the 100000th prime number, which is 1299709. The end of the input is indicated by a line containing a single zero.

Output 

The output should be composed of lines each of which contains a single non-negative integer. It is the length of the prime gap that contains the corresponding positive integer in the input if it is a composite number, or `0' otherwise. No other characters should occur in the output.

Sample Input 

10 
11 
27 
2 
492170 
0

Sample Output 

4 
0 
6 
0 
114


为了完成规定的题数,我只能先找找水题做做了。。。



#include <bits/stdc++.h>
using namespace std;

const int maxn = 1400000;
bool isp[maxn];
int res[maxn];

void init()
{
    isp[0] = isp[1] = false;
    for(int i = 2; i < maxn; i++)
        isp[i] = true;
    int Max = sqrt(maxn) + 1;
    for(int i = 2; i < Max; i++)
        if(isp[i])
            for(int j = 2; i*j < maxn; j++)
                isp[i*j] = false;
    int l, r;
    for(int i = 2; i < maxn; i++){
        if(isp[i]) l = i, res[i] = 0;
        else res[i] = l;
    }
    for(int i = 1299709; i >= 2; --i){
        if(isp[i]) r = i;
        else res[i] = r - res[i];
    }
}

int main()
{
    init();
    int n;
    while(cin >> n, n!=0)
        cout << res[n] << endl;
    return 0;
}


posted @ 2014-12-17 20:42  Popco  阅读(141)  评论(0编辑  收藏  举报