HDUOJ - 1063 / POJ - 1001 Exponentiation

Exponentiation

Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7275    Accepted Submission(s): 2072


Problem Description
Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems.

This problem requires that you write a program to compute the exact value of Rn where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.
 

Input
The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.
 

Output
The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer.
 

Sample Input
95.123 12 0.4321 20 5.1234 15 6.7592 9 98.999 10 1.0100 12
 

Sample Output
548815620517731830194541.899025343415715973535967221869852721 .00000005148554641076956121994511276767154838481760200726351203835429763013462401 43992025569.928573701266488041146654993318703707511666295476720493953024 29448126.764121021618164430206909037173276672 90429072743629540498.107596019456651774561044010001 1.126825030131969720661201

当时做POJ1001的时候使用了自己写的C++大数类,现在用java重写,果然简单方便

当时的代码:
#include <iostream>
#include <cstdlib>
#include <cstdio>
#include <string>
#include <cstring>
#include <vector>
#include <algorithm>
using namespace std;

int size_dec = 0;
vector<int> num;
vector<int> base;

void multi()
{
	vector<int> res(num.size() + base.size(), 0);
	for (int i = 0; i < num.size(); i++)
		for (int j = 0; j < base.size(); j++)
			res[i + j] += num[i] * base[j];
	for (int i = 0; i < res.size() - 1; i++)
	{
		res[i + 1] += res[i] / 10;
		res[i] = res[i] % 10;
	}
	for (int i = res.size() - 1; i >= 0; --i)
	{
		if (res[i] == 0)
			res.pop_back();
		else
			break;
	}
	num.clear();
	num = res;
}


int main()
{
	char str[1024];
	int times;
	while (cin >> str)
	{
		cin >> times;
		num.clear();
		base.clear();
		size_dec = 0;
		//如果输入是小数,去除小数尾部的零
		for (int i = 0; i < strlen(str); ++i)
		{
			if (str[i] == '.')
			{
				for (int j = strlen(str) - 1; j > i; --j)
				{
					if (str[j] == '0')
						str[j] = 0;
					else
						break;
				}
				break;
			}
		}

		for (int i = strlen(str) - 1; i >= 0; --i)
		{
			if (str[i] == '.')
				size_dec = (strlen(str) - 1 - i)*times;
			else
				base.push_back(str[i] - '0');
		}

		//去后面的0
		for (int i = base.size() - 1; i >= 0; --i)
		{
			if (base[i] == 0)
				base.pop_back();
			else
				break;
		}
		num = base;
		for (int i = 0; i < times - 1; i++)
			multi();

		string out;
		if (size_dec == 0)
		{
			for (int i = 0; i < num.size(); i++)
				out.push_back(num[i] + '0');
		}
		else if (num.size() > size_dec)
		{
			for (int i = 0; i < num.size(); i++)
			{
				if (i == size_dec)
					out.push_back('.');
				out.push_back(num[i] + '0');
			}
		}
		else
		{
			for (int i = 0; i < size_dec; i++)
			{
				if (i < num.size())
					out.push_back(num[i] + '0');
				else
					out.push_back('0');
			}
			out.push_back('.');
		}
		for (int i = out.size() - 1; i >= 0; --i)
			printf("%c", out[i]);
		cout << endl;
	}


	return 0;
}



java代码:

import java.math.*;
import java.util.*;
import java.io.*;
import java.text.*;

public class Main {

	public static void main(String[] args) {
		Scanner cin = new Scanner(System.in);
		DecimalFormat t = new DecimalFormat("#.#");
		BigDecimal x, res;
		int y;
		while(cin.hasNextBigDecimal()){
			x = cin.nextBigDecimal();
			y = cin.nextInt();
			res = x.pow(y).stripTrailingZeros();
			System.out.println(res.toPlainString().replaceAll("^0", ""));
		}
	}

}


posted @ 2014-12-18 22:58  Popco  阅读(118)  评论(0编辑  收藏  举报