HDU - 2057 A + B Again

 

Description

There must be many A + B problems in our HDOJ , now a new one is coming. 
Give you two hexadecimal integers , your task is to calculate the sum of them,and print it in hexadecimal too. 
Easy ? AC it !
 

Input

The input contains several test cases, please process to the end of the file. 
Each case consists of two hexadecimal integers A and B in a line seperated by a blank. 
The length of A and B is less than 15.
 

Output

For each test case,print the sum of A and B in hexadecimal in one line. 
 

Sample Input

+A -A +1A 12 1A -9 -1A -12 1A -AA
 

Sample Output

0 2C 11 -2C -90
 



#include <cstdio>
#include <cmath>
#include <cstdlib>

int main()
{
    long long int x, y;
    while(~scanf("%llx %llx", &x, &y)){
        if(x+y < 0) printf("-%llX\n", -(x+y));
        else printf("%llX\n", x+y);
    }
    return 0;
}


posted @ 2014-12-24 09:24  Popco  阅读(184)  评论(0编辑  收藏  举报