HDU - 5150 Sum Sum Sum

Sum Sum Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 166    Accepted Submission(s): 122


Problem Description
We call a positive number X P-number if there is not a positive number that is less than X and the greatest common divisor of these two numbers is bigger than 1.
Now you are given a sequence of integers. You task is to calculate the sum of P-numbers of the sequence.
 

Input
There are several test cases. 
In each test case:
The first line contains a integer N(1N1000). The second line contains N integers. Each integer is between 1 and 1000.
 

Output
For each test case, output the sum of P-numbers of the sequence.
 

Sample Input
3 5 6 7 1 10
 

Sample Output
12 0
 



#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <algorithm>
using namespace std;

int gcd(int x, int y)
{
    return y==0 ? x : gcd(y, x % y);
}

bool is_p(int x)
{
    for(int i = 2; i < x; i++)
        if( gcd(x, i) >= 2 )
            return false;
    return true;
}

int main()
{
    int N;
    while(cin >> N)
    {
        int sum = 0;
        while(N--)
        {
            int x; cin >> x;
            if(is_p(x))
                sum += x;
        }
        printf("%d\n",sum);
    }
    return 0;
}


posted @ 2014-12-29 18:41  Popco  阅读(117)  评论(0编辑  收藏  举报