hoj 1003 Mixing Milk

Since milk packaging is such a low margin business, it is important to keep the price of the raw product (milk) as low as possible. Help Merry Milk Makers get the milk they need in the cheapest possible manner.

The Merry Milk Makers company has several farmers from which they may buy milk, and each one has a (potentially) different price at which they sell to the milk packing plant. Moreover, as a cow can only produce so much milk a day, the farmers only have so much milk to sell per day. Each day, Merry Milk Makers can purchase an integral amount of milk from each farmer, less than or equal to the farmer's limit.

Given the Merry Milk Makers' daily requirement of milk, along with the cost per gallon and amount of available milk for each farmer, calculate the minimum amount of money that it takes to fulfill the Merry Milk Makers' requirements.

Note: The total milk produced per day by the farmers will be sufficient to meet the demands of the Merry Milk Makers.

Input

The first line contains two integers, N and M. The first value, N, (0 <= N <= 2,000,000) is the amount of milk that Merry Milk Makers' want per day. The second, M, (0 <= M <= 5,000) is the number of farmers that they may buy from.

The next M lines (Line 2 through M+1) each contain two integers, Pi and Ai. Pi (0 <= Pi <= 1,000) is price in cents that farmer i charges. Ai (0 <= Ai <= 2,000,000) is the amount of milk that farmer i can sell to Merry Milk Makers per day.

Output

A single line with a single integer that is the minimum price that Merry Milk Makers can get their milk at for one day.

Sample Input

100 5
5 20
9 40
3 10
8 80
6 30

Sample Output

630
 
分析: 记得第一次写这道题是在sse上,当时不会写就水过去了。但是这次好好分析了一下,发现这其实是一道很简单的贪心题目。
#include <stdio.h>
typedef struct milk{
    int p;         //价格
    int a;        //
} MILK;
void sort(MILK famers[],int M)
{
    int i,j,k;
    MILK t;
    for(i=0;i<M-1;i++)
    {
        k=i;
        for(j=i;j<M;j++)
        {
            if(famers[j].p<famers[k].p)
                k=j;
        }
        if(k!=i)
        {
            t=famers[i];
            famers[i]=famers[k];
            famers[k]=t;
        }
    }
}
MILK famers[5002];                 //定义一个数组储存每个农民的单价和总量的信息
int main()
{

    int N,M;                       //N是需要购买的牛奶,M是农民的数目
    int psum=0,asum=0;
    int last,i;
    scanf("%d %d",&N,&M);
    for(i=0;i<M;i++)
        scanf("%d %d",&famers[i].p,&famers[i].a);
    sort(famers,M);                //由单价低向单价高排序
    for(i=0;i<M;i++)
    {
        if((asum+famers[i].a)<=N)
        {
            asum+=famers[i].a;
            psum+=famers[i].p*famers[i].a;
        }
        else
        {
            last=N-asum;
            asum+=last;
            psum+=last*famers[i].p;
            break;
        }
    }
    printf("%d\n",psum);
    return 0;
}
posted @ 2015-12-25 16:47  小白酷狗  阅读(401)  评论(0编辑  收藏  举报