Spell checker
Description
You, as a member of a development team for a new spell checking program, are to write a module that will check the correctness of given words using a known dictionary of all correct words in all their forms.
If the word is absent in the dictionary then it can be replaced by correct words (from the dictionary) that can be obtained by one of the following operations:
?deleting of one letter from the word;
?replacing of one letter in the word with an arbitrary letter;
?inserting of one arbitrary letter into the word.
Your task is to write the program that will find all possible replacements from the dictionary for every given word.
If the word is absent in the dictionary then it can be replaced by correct words (from the dictionary) that can be obtained by one of the following operations:
?deleting of one letter from the word;
?replacing of one letter in the word with an arbitrary letter;
?inserting of one arbitrary letter into the word.
Your task is to write the program that will find all possible replacements from the dictionary for every given word.
Input
The first part of the input file contains all words from the dictionary. Each word occupies its own line. This part is finished by the single character '#' on a separate line. All words are different. There will be at most 10000 words in the dictionary.
The next part of the file contains all words that are to be checked. Each word occupies its own line. This part is also finished by the single character '#' on a separate line. There will be at most 50 words that are to be checked.
All words in the input file (words from the dictionary and words to be checked) consist only of small alphabetic characters and each one contains 15 characters at most.
The next part of the file contains all words that are to be checked. Each word occupies its own line. This part is also finished by the single character '#' on a separate line. There will be at most 50 words that are to be checked.
All words in the input file (words from the dictionary and words to be checked) consist only of small alphabetic characters and each one contains 15 characters at most.
Output
Write to the output file exactly one line for every checked word in the order of their appearance in the second part of the input file. If the word is correct (i.e. it exists in the dictionary) write the message: " is correct". If the word is not correct then write this word first, then write the character ':' (colon), and after a single space write all its possible replacements, separated by spaces. The replacements should be written in the order of their appearance in the dictionary (in the first part of the input file). If there are no replacements for this word then the line feed should immediately follow the colon.
Sample Input
i is has have be my more contest me too if award # me aware m contest hav oo or i fi mre #
Sample Output
me is correct aware: award m: i my me contest is correct hav: has have oo: too or: i is correct fi: i mre: more me
题目大意:输入字典中的单词,以#结束,再输入要查找的单词,也以#结束
若在字典中找到了,则输出:x is correct;
若在字典中找到单词满足或者更改一个字母,或者删除一个字母,或者增加一个字母之后成为要查找的单词,就按照字典序输出;
若是以上两种都没有找到,则不输出;
代码:
1 #include<iostream> 2 #include<cstdio> 3 #include<cstring> 4 #include<cstdlib> 5 using namespace std; 6 char dic[100000][82],word[100000][82]; 7 int dicnum=0,wordnum=0; 8 void add() 9 { 10 while(scanf("%s",dic[dicnum])&&dic[dicnum][0]!='#') 11 dicnum++; 12 while(scanf("%s",word[wordnum])&&word[wordnum][0]!='#') 13 wordnum++; 14 dicnum--; 15 wordnum--; 16 //cout<<wordnum<<endl<<dicnum; 17 } 18 int change(char f[],char g[])//f是字典中的单词,g是查找的单词 19 { 20 int i=0; 21 int t=0; 22 for(i=0;f[i]!='\0';i++) 23 { 24 if(f[i]!=g[i]) 25 { 26 t++; 27 if(t==2)return 0; 28 } 29 } 30 return 1; 31 } 32 int zeng(char f[],char g[])//g大 33 { 34 int s=0,t=0,zong=0; 35 while(g[t]!='\0') 36 { 37 if(f[s]!=g[t]) 38 { 39 zong++; 40 t++; 41 if(zong==2)return 0; 42 } 43 else 44 { 45 s++; 46 t++; 47 } 48 } 49 return 1; 50 } 51 int shan(char f[],char g[])//f大 52 { 53 int s=0,t=0,zong=0; 54 while(f[s]!='\0') 55 { 56 if(f[s]!=g[t]) 57 { 58 zong++; 59 s++; 60 if(zong==2)return 0; 61 } 62 else 63 { 64 s++; 65 t++; 66 } 67 } 68 return 1; 69 } 70 int main() 71 { 72 add(); 73 int diclen[100000]={0}; 74 int i,j; 75 for(i=0;i<=dicnum;i++) 76 diclen[i]=strlen(dic[i]); 77 for(i=0;i<=wordnum;i++) 78 { 79 int f[100000],t=0,flag=0,s=0,zong=0; 80 int len=strlen(word[i]); 81 for( j=0;j<=dicnum;j++) 82 { 83 if(strcmp(dic[j],word[i])==0) 84 { 85 flag=1; 86 break; 87 } 88 else if(diclen[j]==len) 89 { 90 s=change(dic[j],word[i]); 91 if(s==1) 92 { 93 f[t++]=j; 94 zong++; 95 } 96 } 97 else if(diclen[j]-len==-1) 98 { 99 s=zeng(dic[j],word[i]); 100 if(s==1)f[t++]=j; 101 } 102 else if(diclen[j]-len==1) 103 { 104 s=shan(dic[j],word[i]); 105 if(s==1) 106 { 107 f[t++]=j; 108 zong++; 109 } 110 } 111 } 112 if(flag==1) 113 { 114 cout<<word[i]<<' '<<"is"<<' '<<"correct"<<endl; 115 continue; 116 } 117 else 118 { 119 //if(zong==0)continue; 120 cout<<word[i]<<": "; 121 int st=0; 122 for(j=0;j<=t-1;j++) 123 { 124 if(st==0) 125 { 126 cout<<dic[f[j]]; 127 st=1; 128 } 129 else 130 cout<<" "<<dic[f[j]]; 131 } 132 cout<<endl; 133 } 134 } 135 return 0; 136 }