HDU 2639 Bone Collector II (01背包求第K大解)

Bone Collector II

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 916    Accepted Submission(s): 437


Problem Description
The title of this problem is familiar,isn't it?yeah,if you had took part in the "Rookie Cup" competition,you must have seem this title.If you haven't seen it before,it doesn't matter,I will give you a link:

Here is the link:http://acm.hdu.edu.cn/showproblem.php?pid=2602

Today we are not desiring the maximum value of bones,but the K-th maximum value of the bones.NOTICE that,we considerate two ways that get the same value of bones are the same.That means,it will be a strictly decreasing sequence from the 1st maximum , 2nd maximum .. to the K-th maximum.

If the total number of different values is less than K,just ouput 0.
 

 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, K(N <= 100 , V <= 1000 , K <= 30)representing the number of bones and the volume of his bag and the K we need. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

 

Output
One integer per line representing the K-th maximum of the total value (this number will be less than 231).
 

 

Sample Input
3 5 10 2 1 2 3 4 5 5 4 3 2 1 5 10 12 1 2 3 4 5 5 4 3 2 1 5 10 16 1 2 3 4 5 5 4 3 2 1
 

 

Sample Output
12 2 0
 

 

Author
teddy
 

 

Source
 

 

Recommend
teddy
 
 
/*
HDU  2639
求01背包的第k大解。
合并两个有序序列
*/

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<algorithm>
using namespace std;
const int MAXN=110;
int dp[1010][50];//dp[i][j]表示容量为i,第j大的值
int value[MAXN];
int weight[MAXN];

int a[50];
int b[50];

int N,V,K;

void DP()
{
    memset(dp,0,sizeof(dp));
    for(int i=0;i<N;i++)
       for(int j=V;j>=value[i];j--)
       {
           for(int k=1;k<=K;k++)
           {
               a[k]=dp[j][k];
               b[k]=dp[j-value[i]][k]+weight[i];
           }
           int x,y,z;
           x=y=z=1;
           a[K+1]=b[K+1]=-1;//这个一定要
           while(z<=K&&(x<=K||y<=K))//合并两个已经排好序的序列
           {
               if(a[x]>b[y])dp[j][z]=a[x++];
               else dp[j][z]=b[y++];

               if(dp[j][z]!=dp[j][z-1])z++;
           }
       }
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d%d",&N,&V,&K);
        for(int i=0;i<N;i++)scanf("%d",&weight[i]);
        for(int i=0;i<N;i++)scanf("%d",&value[i]);
        DP();
        printf("%d\n",dp[V][K]);
    }
    return 0;
}

 

posted on 2012-09-14 15:51  kuangbin  阅读(563)  评论(0编辑  收藏  举报

导航

JAVASCRIPT: