HDU 1266 Reverse Number (很简单的水题)
Reverse Number
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2047 Accepted Submission(s): 926
Problem Description
Welcome to 2006'4 computer college programming contest!
Specially, I give my best regards to all freshmen! You are the future of HDU ACM! And now, I must tell you that ACM problems are always not so easy, but, except this one... Ha-Ha!
Give you an integer; your task is to output its reverse number. Here, reverse number is defined as follows:
1. The reverse number of a positive integer ending without 0 is general reverse, for example, reverse (12) = 21;
2. The reverse number of a negative integer is negative, for example, reverse (-12) = -21;
3. The reverse number of an integer ending with 0 is described as example, reverse (1200) = 2100.
Specially, I give my best regards to all freshmen! You are the future of HDU ACM! And now, I must tell you that ACM problems are always not so easy, but, except this one... Ha-Ha!
Give you an integer; your task is to output its reverse number. Here, reverse number is defined as follows:
1. The reverse number of a positive integer ending without 0 is general reverse, for example, reverse (12) = 21;
2. The reverse number of a negative integer is negative, for example, reverse (-12) = -21;
3. The reverse number of an integer ending with 0 is described as example, reverse (1200) = 2100.
Input
Input file contains multiple test cases. There is a positive integer n (n<100) in the first line, which means the number of test cases, and then n 32-bit integers follow.
Output
For each test case, you should output its reverse number, one case per line.
Sample Input
3
12
-12
1200
Sample Output
21
-21
2100
Author
lcy
Source
Recommend
lxj
/*
HDU 1266
水题,但是要用字符串去存储,并不像题目说的是整型的
数据很大
*/
#include<stdio.h>
#include<string.h>
int main()
{
char m[100];
long long x;
int T,i;
int t;
scanf("%d",&T);
while(T--)
{
scanf("%s",&m);
int k=strlen(m);
for(t=k-1;t>=0;t--)
if(m[t]!='0') break;
if(m[0]=='-')
{
printf("-");
for(i=t;i>=1;i--)
printf("%c",m[i]);
for(i=t+1;i<k;i++)
printf("0");
}
else
{
for(i=t;i>=0;i--)
printf("%c",m[i]);
for(i=t+1;i<k;i++)
printf("0");
}
printf("\n");
}
return 0;
}
人一我百!人十我万!永不放弃~~~怀着自信的心,去追逐梦想