ACM HDU 1196 Lowest Bit(简单水题)
Lowest Bit
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3399 Accepted Submission(s): 2426
Problem Description
Given an positive integer A (1 <= A <= 100), output the lowest bit of A.
For example, given A = 26, we can write A in binary form as 11010, so the lowest bit of A is 10, so the output should be 2.
Another example goes like this: given A = 88, we can write A in binary form as 1011000, so the lowest bit of A is 1000, so the output should be 8.
For example, given A = 26, we can write A in binary form as 11010, so the lowest bit of A is 10, so the output should be 2.
Another example goes like this: given A = 88, we can write A in binary form as 1011000, so the lowest bit of A is 1000, so the output should be 8.
Input
Each line of input contains only an integer A (1 <= A <= 100). A line containing "0" indicates the end of input, and this line is not a part of the input data.
Output
For each A in the input, output a line containing only its lowest bit.
Sample Input
26
88
0
Sample Output
2
8
Author
SHI, Xiaohan
Source
Recommend
Ignatius.L
很简单的水题:
#include<stdio.h>
int main()
{
int A,t;
while(scanf("%d",&A),A)
{
t=1;
while(A)
{
if(A%2==1)break;
A/=2;
t*=2;
}
printf("%d\n",t);
}
return 0;
}
人一我百!人十我万!永不放弃~~~怀着自信的心,去追逐梦想