ACM HDU 1021Fibonacci Again
Fibonacci Again
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15017 Accepted Submission(s): 7022
Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
Output
Print the word "yes" if 3 divide evenly into F(n).
Print the word "no" if not.
Print the word "no" if not.
Sample Input
0
1
2
3
4
5
Sample Output
no
no
yes
no
no
no
Author
Leojay
Recommend
JGShining
找规律:
#include<iostream>
using namespace std;
int main()
{
int n;
while(cin>>n)
{
if(n%4==2)cout<<"yes"<<endl;
else cout<<"no"<<endl;
}
return 0;
}
人一我百!人十我万!永不放弃~~~怀着自信的心,去追逐梦想