POJ 1742 Coins

People in Silverland use coins.They have coins of value A1,A2,A3...An Silverland dollar.One day Tony opened his money-box and found there were some coins.He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch. 
You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins. 

Input

The input contains several test cases. The first line of each test case contains two integers n(1<=n<=100),m(m<=100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1<=Ai<=100000,1<=Ci<=1000). The last test case is followed by two zeros.

Output

For each test case output the answer on a single line.

Sample Input

3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0

Sample Output

8
4

暴力dp

完全背包啊,dp[j] 记录的是 j 这个价值能否有之前的硬币组合出来。
sum[j] 记录的是用之前组合出来的价值 和 第i种硬币组合出新的价值j所需要的第i种硬币的个数。

#include<cstdio>
#include<cstring>
int A[105], C[105];
int dp[100005],sum[100005];

int main(){
    int n, m;
    while(scanf("%d%d",&n,&m),n|m){
        for(int i=0;i<n;i++)
            scanf("%d",&A[i]);
        for(int i=0;i<n;i++)
            scanf("%d",&C[i]);

        int ans = 0;
        memset(dp,0,sizeof(dp));
        dp[0] = 1;
        for(int i=0;i<n;i++){
            memset(sum,0,sizeof(sum));
            for(int j=A[i];j<=m;j++){
                if(!dp[j] && dp[j-A[i]] && sum[j-A[i]]<C[i]){
                    dp[j] = 1;
                    sum[j] = sum[j-A[i]]+1;
                    ans ++;
                }
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}
View Code

 

posted @ 2019-02-03 19:49  kongbb  阅读(113)  评论(0编辑  收藏  举报