关闭页面特效

A + B Problem II

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

 

Sample Input
2 1 2 112233445566778899 998877665544332211
 

 

Sample Output
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 
代码 如下,为了 省事 ,我用C#写的控制台 程序,并且考虑有点 不太周全 ,只考虑到了A数字长度 大于等于B数字的情况。
 
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
using System;
using System.Text;
 
namespace TestSum
{
    class Program
    {
        static void Main(string[] args)
        {
            long a = 112233445566778899;
            long b = 998877665544332211;
 
            //long a = 123;
            //long b = 29;
 
            char[] ac = a.ToString().ToCharArray();
            char[] bc = b.ToString().ToCharArray();
            StringBuilder result = new StringBuilder();
            if(ac.Length>=bc.Length)
            {
 
                int temp = 0;
 
                for (int i = ac.Length - 1, j = bc.Length-1; i>=0; i--,j--)
                {
                     
                    int indexValue = 0;
 
                    if (temp == 1)
                    {
                        indexValue++;
                    }
                    int _a = 0, _b = 0;
                    if(j<0)
                    {
                        _b = 0;
                        _a = int.Parse(ac[i].ToString());
                    }
                     else
                    {
                        _a = int.Parse(ac[i].ToString());
                        _b = int.Parse(bc[j].ToString());
                    }
      
                    if(_a+_b>9)
                    {
                        indexValue+= ((_a + _b-10 ));
                        temp = 1;
                    }
                    else
                    {
                        indexValue+= (_a + _b);
                        temp = 0;
                    }
 
                     
 
                    result.Append(indexValue);
                }
            }
 
          reverse(result.ToString());
            Console.ReadKey();
 
         
        }
 
       static void reverse(string result)
        {
            for(int i =result.Length-1;i>=0;i--)
            {
                Console.Write(result[i]);
            }
        }
    }
}

  


__EOF__

作  者ღKawaii
出  处https://www.cnblogs.com/kmsfan/p/7471405.html
关于博主:一个普通的小码农,为了梦想奋斗
版权声明:署名 - 非商业性使用 - 禁止演绎,协议普通文本 | 协议法律文本
声援博主:如果您觉得文章对您有帮助,可以点击文章右下角推荐一下。您的鼓励是博主的最大动力!

posted @   yangliwen  阅读(358)  评论(0编辑  收藏  举报
编辑推荐:
· Linux系列:如何用 C#调用 C方法造成内存泄露
· AI与.NET技术实操系列(二):开始使用ML.NET
· 记一次.NET内存居高不下排查解决与启示
· 探究高空视频全景AR技术的实现原理
· 理解Rust引用及其生命周期标识(上)
阅读排行:
· 阿里最新开源QwQ-32B,效果媲美deepseek-r1满血版,部署成本又又又降低了!
· 单线程的Redis速度为什么快?
· SQL Server 2025 AI相关能力初探
· 展开说说关于C#中ORM框架的用法!
· AI编程工具终极对决:字节Trae VS Cursor,谁才是开发者新宠?
历史上的今天:
2015-09-03 算法导论 - 函数的增长。
0
0
关注
跳至底部
document.getElementById("homeTopTitle").innerText="ღKawaii";
点击右上角即可分享
微信分享提示