poj 2096 Collecting Bugs

Ivan is fond of collecting. Unlike other people who collect post stamps, coins or other material stuff, he collects software bugs. When Ivan gets a new program, he classifies all possible bugs into n categories. Each day he discovers exactly one bug in the program and adds information about it and its category into a spreadsheet. When he finds bugs in all bug categories, he calls the program disgusting, publishes this spreadsheet on his home page, and forgets completely about the program. 
Two companies, Macrosoft and Microhard are in tight competition. Microhard wants to decrease sales of one Macrosoft program. They hire Ivan to prove that the program in question is disgusting. However, Ivan has a complicated problem. This new program has s subcomponents, and finding bugs of all types in each subcomponent would take too long before the target could be reached. So Ivan and Microhard agreed to use a simpler criteria --- Ivan should find at least one bug in each subsystem and at least one bug of each category. 
Macrosoft knows about these plans and it wants to estimate the time that is required for Ivan to call its program disgusting. It's important because the company releases a new version soon, so it can correct its plans and release it quicker. Nobody would be interested in Ivan's opinion about the reliability of the obsolete version. 
A bug found in the program can be of any category with equal probability. Similarly, the bug can be found in any given subsystem with equal probability. Any particular bug cannot belong to two different categories or happen simultaneously in two different subsystems. The number of bugs in the program is almost infinite, so the probability of finding a new bug of some category in some subsystem does not reduce after finding any number of bugs of that category in that subsystem. 
Find an average time (in days of Ivan's work) required to name the program disgusting.

Input

Input file contains two integer numbers, n and s (0 < n, s <= 1 000).

Output

Output the expectation of the Ivan's working days needed to call the program disgusting, accurate to 4 digits after the decimal point.

Sample Input

1 2

Sample Output

3.0000
解题思路;
概率dp,
一个软件有s个子系统,会产生n种bug,问发现n种bug,每个子系统都发现bug的天数的期望
那么dp[i][j]就代表已经找到属于j个系统的i个bug时的期望值,也就是需要多少天,设需要m天dp[0][0]=m,当i=n,j=s时,天数为0,则有dp[n][s]=0,求dp[0][0]。

那么dp[i][j]就有四种状态了:
1.dp[i][j]  属于已经有的i个分类和j个系统 概率为 i/n*j/s ;
2.dp[i+1][j] 属于已有的j个系统和未有的分类 概率为 (1-i/n)*j/s;
3.dp[i][j+1] 属于已有的i个分类和未有的系统 概率为 (1-j/s)*i/n;
4.dp[i+1][j+1] 不属于已有的分类和系统 概率为 (1-i/n)*(1-j/s)
dp[i][j]是等于这四个中状态的概率之和,所以可以得出状态转移方程
dp[i][j] = p1*dp[i][j]+p2*[i+1][j]+p3*[i][j+1]+p4*[i+1][j+1];
将状态转移方程移位下可得:
dp[i][j]=((s-j)*i*dp[i][j+1]+(n-i)*j*dp[i+1][j]+(s-j)*(n-i)*dp[i+1][j+1]+n*s)/(n*s-i*j);

实现方程:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
const int MAXN=1009;
double dp[MAXN][MAXN];
int main()
{
    int n,s,i,j;
    while(cin>>n>>s){
    dp[n][s] = 0;
    for(i=n;i>=0;i--){
        for(j=s;j>=0;j--){
            if(i==n&&j==s)continue;
                dp[i][j]=((s-j)*i*dp[i][j+1]+(n-i)*j*dp[i+1][j]+(s-j)*(n-i)*dp[i+1][j+1]+n*s)/(n*s-i*j);
        }
    }
    printf("%.4f\n",dp[0][0]);
    }
    return 0;
}

 

posted @ 2017-07-26 15:46  冥想选手  阅读(149)  评论(2编辑  收藏  举报