第十二周作业

第十二周作业

这个作业属于那个课程 C语言程序设计II
这个作业要求在哪里 https://edu.cnblogs.com/campus/zswxy/software-engineering-class1-2018/homework/3235
我在这个课程的目标是 二级指针的概念,以及指针数组的应用;了解指针与函数的关系,掌握指针作为函数返回值;掌握单向链表的概念和操作(建立、增加、删除、修改、遍历)
这个作业在那个具体方面帮助我实现目标 通过pta的三个函数题学习
参考文献

函数题一:计算最长的字符串长度

本题要求实现一个函数,用于计算有n个元素的指针数组s中最长的字符串的长度。

函数接口定义:

int max_len( char *s[], int n );

其中n个字符串存储在s[]中,函数max_len应返回其中最长字符串的长度。

裁判测试程序样例:

#include <stdio.h>
#include <string.h>
#include <stdlib.h>

#define MAXN 10
#define MAXS 20

int max_len( char *s[], int n );

int main()
{
int i, n;
char *string[MAXN] = {NULL};

scanf("%d", &n);
for(i = 0; i < n; i++) {
    string[i] = (char *)malloc(sizeof(char)*MAXS);
    scanf("%s", string[i]);
}
printf("%d\n", max_len(string, n));

return 0;
}

/* 你的代码将被嵌在这里 */

输入样例:

4
blue
yellow
red
green

输出样例:

6

实验代码:

int max_len( char *s[], int n ){
int max=0;
int i,j;

for(i=0;i<n;i++){
	if(strlen(s[max])<strlen(s[i])){
		max=i;	
	}
}	
return strlen(s[max]);
} 

运行结果截图:

思路解析:

函数题二:统计专业人数:

本题要求实现一个函数,统计学生学号链表中专业为计算机的学生人数。链表结点定义如下:

struct ListNode {
char code[8];
struct ListNode *next;
};

这里学生的学号共7位数字,其中第2、3位是专业编号。计算机专业的编号为02。

函数接口定义:

int countcs( struct ListNode *head );

其中head是用户传入的学生学号链表的头指针;函数countcs统计并返回head链表中专业为计算机的学生人数。

裁判测试程序样例:

#include <stdio.h>
#include <stdlib.h>
#include <string.h>

struct ListNode {
char code[8];
struct ListNode *next;
};

struct ListNode *createlist(); /*裁判实现,细节不表*/
 int countcs( struct ListNode *head );

  int main()
    {
   struct ListNode  *head;

head = createlist();
printf("%d\n", countcs(head));

return 0;
  }

    /* 你的代码将被嵌在这里 */

输入样例:

1021202
2022310
8102134
1030912
3110203
4021205
#

输出样例:

3

实验代码:

int countcs( struct ListNode *head )
{ 

int num = 0;
struct ListNode *p = head;
while(p != NULL)
{
    if(p->code[1] == '0' && p->code[2] == '2')
        num++;
    p = p->next;
}
return num;
} 

运行结果截图:

思路解析:

函数题三:删除单链表偶数节点

本题要求实现两个函数,分别将读入的数据存储为单链表、将链表中偶数值的结点删除。链表结点定义如下:

struct ListNode {
 int data;
struct ListNode *next;
};

函数接口定义:

struct ListNode *createlist();
struct ListNode *deleteeven( struct ListNode *head );

函数createlist从标准输入读入一系列正整数,按照读入顺序建立单链表。当读到−1时表示输入结束,函数应返回指向单链表头结点的指针。

函数deleteeven将单链表head中偶数值的结点删除,返回结果链表的头指针。

裁判测试程序样例:

#include <stdio.h>
#include <stdlib.h>

struct ListNode {
int data;
struct ListNode *next;
};

struct ListNode *createlist();
 struct ListNode *deleteeven( struct ListNode *head );
  void printlist( struct ListNode *head )
  {
 struct ListNode *p = head;
 while (p) {
       printf("%d ", p->data);
       p = p->next;
 }
 printf("\n");
 }

 int main()
  {
struct ListNode *head;

head = createlist();
head = deleteeven(head);
printlist(head);

return 0;
}

   /* 你的代码将被嵌在这里 */

输入样例:

1 2 2 3 4 5 6 7 -1

输出样例:

1 3 5 7 

实验代码:

struct ListNode *createlist()
{
struct ListNode *head,*p,*p1;
int data;
head=(struct ListNode*)malloc(sizeof(struct ListNode));

head->next=NULL;
p1=head;

while(1)
{
   p=(struct ListNode*)malloc(sizeof(struct ListNode));
    scanf("%d",&data);
    if(data==-1)
        break;
    p->data=data;
    p->next=NULL;
    p1->next=p;
    p1=p;
}
return head;
  };

  struct ListNode *deleteeven( struct ListNode *head )
 {
struct ListNode *p1,*p2;

while(head!=NULL&&head->data%2==0)
{
    p2=head;
    head=head->next;
    free(p2);
}
p1 = head;
while(p1!=NULL){
    while(p1->next && p1->next->data%2==0){
        p2= p1->next;
        p1->next = p2->next;
    }
    p1= p1->next;
}
return head;
  }

运行结果截图:

实验思路:这个题不会写看了一下别人的代码有了一点思路

预习作业:

从第十三周开始,将进入课程设计阶段,请在本次作业中给出:

1.所在小组想要开发的项目的名称和目标;

还在构思

2.项目主体功能的描述;

还在构思

3.现阶段已做的准备工作;

网上查找相关资料寻找思路

4.小组成员名单和进度安排。(课程设计阶段:13-17周)

杨梓欣,罗腾龙,徐一涵

学习时间表:

周/日期 这周所花的时间 代码行
3/9-3/15 30mim 35
3/15-3/22 40min 46
3/22-3/29 1h 69
3/29-4/5 50min 87
4/5-4/12 30min 97
4/12-4/19 20min 75
4/19-4/26 1h20min 116
5/5-5/9 3h 79
5/9-5/17 2h 97
posted @ 2019-05-16 16:15  修电脑的阿欣  阅读(157)  评论(1编辑  收藏  举报