poj 1007 DNA sorting (qsort)

DNA Sorting
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 95209   Accepted: 38311

Description

One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be---exactly the reverse of sorted). 

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length. 

Input

The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.

Output

Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.

Sample Input

10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT

Sample Output

CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA

C/C++代码

#include <stdio.h>
#include <string.h>
#include <stdlib.h>

struct Str{
    char str[51];
    int inversions;
}data[100];

int inversionNumber(char s[]) {
    
    int len = strlen(s);
    int result = 0;
    int A = 0, C = 0, G = 0;
    int i = len - 1;
    for(; i >= 0; i--)
        switch (s[i]) {
            case 'A':
                A++;
                break;
            case 'C':
                result += A;
                C++;
                break;
            case 'G':
                result = result + A + C;
                G++;
                break;
            case 'T':
                result = result + A + C + G;
                break;
            }
    return result;
}

int cmp(const void * a, const void * b) {
    
    struct Str* c = (struct Str *)a;
    struct Str* d = (struct Str *)b;
    return c->inversions - d->inversions;
    
}

int main(int argc, const char * argv[]) {
    
    int length, number;
    int i;
    scanf("%d%d", &length, &number);

    
    for (i = 0; i < number; i ++) {
        scanf("%s", data[i].str);
        data[i].inversions = inversionNumber(data[i].str);
    }
    
    qsort(data, number, sizeof(data[0]), cmp);
    
    for (i = 0; i < number; i ++) {
        printf("%s\n", data[i].str);
    }
    
    return 0;
}

 

posted @ 2016-06-15 15:57  kk_kk  阅读(204)  评论(0编辑  收藏  举报