Chores

Chores
Time Limit: 3000MS   Memory Limit: 30000K
Total Submissions: 3723   Accepted: 1759

Description

Farmer John's family pitches in with the chores during milking, doing all the chores as quickly as possible. At FJ's house, some chores cannot be started until others have been completed, e.g., it is impossible to wash the cows until they are in the stalls. 

Farmer John has a list of N (3 <= N <= 10,000) chores that must be completed. Each chore requires an integer time (1 <= length of time <= 100) to complete and there may be other chores that must be completed before this chore is started. We will call these prerequisite chores. At least one chore has no prerequisite: the very first one, number 1. Farmer John's list of chores is nicely ordered, and chore K (K > 1) can have only chores 1,.K-1 as prerequisites. Write a program that reads a list of chores from 1 to N with associated times and all perquisite chores. Now calculate the shortest time it will take to complete all N chores. Of course, chores that do not depend on each other can be performed simultaneously.

Input

* Line 1: One integer, N 

* Lines 2..N+1: N lines, each with several space-separated integers. Line 2 contains chore 1; line 3 contains chore 2, and so on. Each line contains the length of time to complete the chore, the number of the prerequisites, Pi, (0 <= Pi <= 100), and the Pi prerequisites (range 1..N, of course). 

Output

A single line with an integer which is the least amount of time required to perform all the chores. 

Sample Input

7
5 0
1 1 1
3 1 2
6 1 1
1 2 2 4
8 2 2 4
4 3 3 5 6

Sample Output

23

Hint

[Here is one task schedule:

Chore 1 starts at time 0, ends at time 5.
Chore 2 starts at time 5, ends at time 6.
Chore 3 starts at time 6, ends at time 9.
Chore 4 starts at time 5, ends at time 11.
Chore 5 starts at time 11, ends at time 12.
Chore 6 starts at time 11, ends at time 19.
Chore 7 starts at time 19, ends at time 23.
]

Source

#include <iostream>
#include <fstream>
#include <vector>
#include <string>
#include <algorithm>
#include <map>
#include <stack>
#include <cmath>
#include <queue>
#include <set>
#define REP(i,j,k) for( int i = j ; i < k ; ++i)


using namespace std;






int main()
{

int least[10001];
int N;
scanf("%d" , &N);

REP(i , 0 , N)
{
least[i] = 0;
}

int t = 0;

REP(i , 0 , N)
{
int length;
cin >> length;
least[i] += length;
int n_pre;
cin >> n_pre;
int max = 0;
while( n_pre -- )
{
int pre;
scanf("%d" , &pre);
max = least[pre - 1] > max?least[pre - 1]: max ;

}

least[i] += max;
t= least[i] > t? least[i]: t;
}


cout << t << endl;


return 0;
}

posted on 2012-01-31 20:37  坑王  阅读(435)  评论(0编辑  收藏  举报

导航