L1-8 估值一亿的AI核心代码 (20 分)

题意

本题要求你实现一个稍微更值钱一点的 AI 英文问答程序,规则是:

无论用户说什么,首先把对方说的话在一行中原样打印出来;
消除原文中多余空格:把相邻单词间的多个空格换成 1 个空格,把行首尾的空格全部删掉,把标点符号前面的空格删掉;
把原文中所有大写英文字母变成小写,除了 I;
把原文中所有独立的 can you、could you 对应地换成 I can、I could—— 这里“独立”是指被空格或标点符号分隔开的单词;
把原文中所有独立的 I 和 me 换成 you;
把原文中所有的问号 ? 换成惊叹号 !;
在一行中输出替换后的句子作为 AI 的回答。

输入格式:
输入首先在第一行给出不超过 10 的正整数 N,随后 N 行,每行给出一句不超过 1000 个字符的、以回车结尾的用户的对话,对话为非空字符串,仅包括字母、数字、空格、可见的半角标点符号。

输出格式:
按题面要求输出,每个 AI 的回答前要加上 AI: 和一个空格。

输入样例:

6
Hello ?
Good to chat with you
can you speak Chinese?
Really?
Could you show me 5
What Is this prime? I,don 't know
输出样例:
Hello ?
AI: hello!
Good to chat with you
AI: good to chat with you
can you speak Chinese?
AI: I can speak chinese!
Really?
AI: really!
Could you show me 5
AI: I could show you 5
What Is this prime? I,don 't know
AI: what Is this prime! you,don't know

考点

c++的string函数的使用
学习到了

代码

#include <bits/stdc++.h>
using namespace std;
#define ll long long
#define pii pair<ll, ll>
const int N = 1e5 + 10;
string a[10000];
bool judge(string &s ,int x,int l ){
    if((x==0 || (!isdigit(s[x-1]) &&!isalpha(s[x-1])))
    &&(x+l==s.length() || (!isalpha(s[x+l])&&!isdigit(s[x+l])) )
    )
    return true;
    else return false;
}
int main()
{
    int t;cin>>t;
    getchar();
    while(t--){
        string  s;
        getline(cin,s);
        cout<<s<<endl;
        while(s[0]==' ') //去掉开头的空格
            s.erase(s.begin());
        while(s[s.length()-1]==' ')//去掉结尾的空格
            s.erase(s.end()-1);
        for(int i=0;i<s.length();i++){
            if(s[i]==' ')
            {
                while(s[i+1]==' '){
                    s.erase(s.begin()+i+1); //去掉多余空格
                }
                if(!isdigit(s[i+1])&&!isalpha(s[i+1])){
                    s.erase(s.begin()+i); //去掉标点前的空格
                }
            }
        }
        while(s[0]==' ') s.erase(s.begin());
        
        for(int i=0;i<s.length();i++){
            if(s[i]!='I'){
                s[i]=tolower(s[i]);
            }
        }
        for(int i=0;;i++){
            i=s.find("can you",i);
            if(i==-1)break;
            if(judge(s,i,7)){
                s.replace(i,7,"A can");//用“...”字符串替换从i开始的7个字符
            } 
        }
		for (int i = 0;; i++)
		{
			i = s.find("could you", i);
			if (i == -1)
				break;
			if (judge(s, i, 9))
				s.replace(i, 9, "A could");
		}
		for (int i = 0;; i++)
		{
			i = s.find("I", i);
			if (i == -1)
				break;
			if (judge(s, i, 1))
				s.replace(i, 1, "you");
		}
		for (int i = 0;; i++)
		{
			i = s.find("me", i);
			if (i == -1)
				break;
			if (judge(s, i, 2))
				s.replace(i, 2, "you");
		}
        for (int i = 0; i < s.length(); i++)
		{
			if (s[i] == '?')
				s[i] = '!';
			else if (s[i] == 'A')//将前面的用A代替的I替换回来
				s[i] = 'I';
		}
		cout << "AI: " << s << "\n";
    }
        return 0;
}

posted @ 2022-04-12 18:30  kingwzun  阅读(123)  评论(0编辑  收藏  举报