The MAX



The MAX

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2366    Accepted Submission(s): 1042


Problem Description
Giving N integers, V1, V2,,,,Vn, you should find the biggest value of F.
 

Input
Each test case contains a single integer N (1<=N<=100). The next line contains N integers, meaning the value of V1, V2....Vn.(1<= Vi <=10^8).The input is terminated by a set starting with N = 0. This set should not be processed.
 

Output
For each test case, output the biggest value of F you can find on a line.
 

Sample Input
2 1 2 0
 

Sample Output
4017
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
using namespace std;
long long a[101];
int main ()
{ 
  int n;
while(scanf("%d",&n))
{
	if(n==0)
	break;
	for(int i=0;i<n;i++)
   {
	scanf("%lld",&a[i]);
    } 
	long long sum=0;
      sort(a,a+n);
      for(int i=0;i<n-1;i++)
   {
	sum+=a[i];
    }
       sum+=a[n-1]*(2010-n);
       printf("%lld\n",sum);
}

	return 0;
}

The MAX

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2366    Accepted Submission(s): 1042


Problem Description
Giving N integers, V1, V2,,,,Vn, you should find the biggest value of F.
 

Input
Each test case contains a single integer N (1<=N<=100). The next line contains N integers, meaning the value of V1, V2....Vn.(1<= Vi <=10^8).The input is terminated by a set starting with N = 0. This set should not be processed.
 

Output
For each test case, output the biggest value of F you can find on a line.
 

Sample Input
2 1 2 0
 

Sample Output
4017
posted @ 2019-12-12 09:01  千金一发  阅读(109)  评论(0编辑  收藏  举报