Pie

Description

My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though. 

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size. 

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different. 
 

Input

One line with a positive integer: the number of test cases. Then for each test case: 
---One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends. 
---One line with N integers ri with 1 <= ri <= 10 000: the radii of the pies. 
 

Output

For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10^(-3).
 

Sample Input

3 3 3 4 3 3 1 24 5 10 5 1 4 2 3 4 5 6 5 4 2
 

Sample Output

25.1327 3.1416 50.2655
给出各个蛋糕半径和客人人数    分蛋糕    给一个人的蛋糕不能是从多个蛋糕上切下来的    主人也是个人 也要算进去  对蛋糕体积二分
#include<cstdio>    
#include<cmath>     
#define pi  acos(-1.0)
double r[10001];  
double s[10001];   
int n,len;
double cha(double mid)  
{  
       int sum=0;  
    for(int i=0;i<n;i++)  
    {  
        sum=sum+(int)(s[i]/mid);  
    }  
    return sum;  
}  
int main()  
{  
  int  t;
  scanf("%d",&t);
    while(t--)  
    {  

	    scanf("%d%d",&n,&len);len++;
          for( int i=0;i<n;i++)  
          {  
            scanf("%lf",&r[i]);  
            s[i]=pi*r[i]*r[i];
          
          }  
        double l=0.0,r=1000000000.0;  //注意这里数组不能开太小  半径最大为10000  r应取  pi*10000*10000以上 
        int s=100;  
        double ans;  
        while(s--)  
        {  
            double mid=(l+r)/2.0;
            if(cha(mid)>=len)  
            {  
                ans=mid;  
                l=mid;  
            }  
            else  
            {  
                r=mid;  
            }  
        }  
        printf("%.4lf\n",ans);  
    }  
    return 0;  
}  


posted @ 2019-12-12 09:00  千金一发  阅读(199)  评论(0编辑  收藏  举报