Lightoj1008
Description
See the picture below.
You are given AB, AC and BC. DE is parallel to BC. You are also given the area ratio between ADE and BDEC. You have to find the value ofAD.
Input
Input starts with an integer T (≤ 25), denoting the number of test cases.
Each case begins with four real numbers denoting AB, AC, BC and the ratio of ADE and BDEC (ADE / BDEC). You can safely assume that the given triangle is a valid triangle with positive area.
Output
For each case of input you have to print the case number and AD. Errors less than 10-6 will be ignored.
Sample Input
4
100 100 100 2
10 12 14 1
7 8 9 10
8.134 9.098 7.123 5.10
Sample Output
Case 1: 81.6496580
Case 2: 7.07106781
Case 3: 6.6742381247
Case 4: 7.437454786
数学题
三角形相似 面积之比等于边之比的平方
#include<cstdio>
#include<cstring>
#include<cmath>
#include<queue>
#include<algorithm>
using namespace std;
int main()
{
int t;
int ans=0;
scanf("%d",&t);
while(t--)
{
ans++;
double a,b,c,d;
scanf("%lf%lf%lf%lf",&a,&b,&c,&d);
double len=a*(sqrt(d)/sqrt(d+1.0));
printf("Case %d: %.6lf\n",ans,len);
}
return 0;
}
编程五分钟,调试两小时...