HDU1098---数学

 

Ignatius's puzzle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9859    Accepted Submission(s): 6898


Problem Description
Ignatius is poor at math,he falls across a puzzle problem,so he has no choice but to appeal to Eddy. this problem describes that:f(x)=5*x^13+13*x^5+k*a*x,input a nonegative integer k(k<10000),to find the minimal nonegative integer a,make the arbitrary integer x ,65|f(x)if
no exists that a,then print "no".

Input
The input contains several test cases. Each test case consists of a nonegative integer k, More details in the Sample Input.
 

 

Output
The output contains a string "no",if you can't find a,or you should output a line contains the a.More details in the Sample Output.
 

 

Sample Input
11
100
9999
 

 

Sample Output
22
no
43
 
 

若a/b=x...0  称a能被b整除,b能整除a,即b|a,读作“b整除a”或“a能被b整除”。a叫做b的倍数,b叫做a的约数(或因数)。

a%b==0

 

摘自discuss

题目大意:

方程f(x)=5*x^13+13*x^5+k*a*x;输入任意一个数k,是否存在一个数a,对任意x都能使得f(x)能被65整除。 现假设存在这个数a ,因为对于任意x方程都成立 所以,当x=1时f(x)=18+ka 又因为f(x)能被65整出,故设n为整数 可得,f(x)=n*65; 即:18+ka=n*65; n为整数 则问题转化为, 对于给定范围的a只需要验证, 是否存在一个a使得(18+k*a)%65==0 所以容易解得 注意,这里有童鞋不理解为毛a只需到65即可 因为,当a==66时 也就相当于已经找了一个周期了,所以再找下去也找不到适当的a了
(18+k*a)%65=(18%65+k*a%65)%65;
当a=66时k*66%65==k%65(即a=1时)


#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<cmath>
#include<string>
#include<algorithm>
using namespace std;
#define MA 10010
int main()
{
 int n,i,k;
 while(~scanf("%d",&k))
 {
     for(i=1;i<=65;i++)
     {
         if((18+i*k)%65==0)
           {
              printf("%d\n",i);
              break;
           }
     }
     if(i>=66)
        printf("no\n");
 }

    return 0;
}

 

 

 
posted @ 2017-07-05 20:38  kimsimple  阅读(811)  评论(0编辑  收藏  举报