poj3468(区间更新)
A Simple Problem with Integers
Time Limit: 5000MS | Memory Limit: 131072K | |
Total Submissions: 105705 | Accepted: 33019 | |
Case Time Limit: 2000MS |
Description
You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.
Input
The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1,
A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of Aa,
Aa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of Aa, Aa+1, ... ,
Ab.
Output
You need to answer all Q commands in order. One answer in a line.
Sample Input
10 5 1 2 3 4 5 6 7 8 9 10 Q 4 4 Q 1 10 Q 2 4 C 3 6 3 Q 2 4
Sample Output
4 55 9 15
Hint
The sums may exceed the range of 32-bit integers.//注意这个条件
//区间更新
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int maxn=100000;
#define LL long long
LL tree[maxn*4];
LL mark[maxn*4];
void build(int l,int r,int rt){
mark[rt]=0;
if(l==r){
scanf("%I64d",&tree[rt]);
return;
}
int m=(l+r)>>1;
build(l,m,rt<<1);
build(m+1,r,rt<<1|1);
tree[rt]=tree[rt<<1]+tree[rt<<1|1] ;
}
void pushDown(int rt,int m){
if(mark[rt]){
mark[rt<<1]+=mark[rt];
mark[rt<<1|1]+=mark[rt];
tree[rt<<1]+=mark[rt]*(m-(m>>1));
tree[rt<<1|1]+=mark[rt]*(m>>1);
mark[rt]=0;
}
}
LL query(int L,int R,int l,int r,int rt){
if(L<=l&&R>=r)
return tree[rt];
pushDown(rt,r-l+1);
int m=(l+r)>>1;
LL ret=0;
if(L<=m) ret+=query(L,R,l,m,rt<<1);
if(R>m) ret+=query(L,R,m+1,r,rt<<1|1);
return ret;
}
void update(int L,int R,int c,int l,int r,int rt){
if(L<=l&&R>=r){
mark[rt]+=c;
tree[rt]+=(LL)c*(r-l+1);
return;
}
pushDown(rt,r-l+1);
int m=(r+l)>>1;
if(L<=m)
update(L,R,c,l,m,rt<<1);
if(R>m)
update(L,R,c,m+1,r,rt<<1|1);
tree[rt]=tree[rt<<1]+tree[rt<<1|1];
}
int main(){
int n,m;
while(~scanf("%d%d",&n,&m)){
memset(tree,0,sizeof(tree));
memset(mark,0,sizeof(mark));
build(1,n,1);
while(m--){
char c[5];
int a,b,d;
scanf("%s",&c);
if(c[0]=='Q'){
scanf("%d%d",&a,&b);
printf("%I64d\n",query(a,b,1,n,1));
}
if(c[0]=='C'){
scanf("%d%d%d",&a,&b,&d);
update(a,b,d,1,n,1);
}
}
}
return 0;
}