hdu 4027 Can you answer these queries?

Can you answer these queries?

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others) Total Submission(s): 15334    Accepted Submission(s): 3595
Problem Description
A lot of battleships of evil are arranged in a line before the battle. Our commander decides to use our secret weapon to eliminate the battleships. Each of the battleships can be marked a value of endurance. For every attack of our secret weapon, it could decrease the endurance of a consecutive part of battleshi ps by make their endurance to the square root of it original value of endurance. During the series of attack of our secret weapon, the commander wants to  evaluate the effect of the weapon, so he asks you for help. You are asked to answer the queries that the sum of the endurance of a consecutive part of the battleship line. Notice that the square root operation should be rounded down to integer.
 
Input
The input contains several test cases, terminated by EOF.   For each test case, the first line contains a single integer N, denoting there are N battleships of evil in a line. (1 <= N <= 100000)   The second line contains N integers Ei, indicating the endurance value of each battleship from the beginning of the line to the end. You can assume that the sum of all endurance value is less than 263.   The next line contains an integer M, denoting the number of actions and queries. (1 <= M <= 100000)   For the following M lines, each line contains three integers T, X and Y. The T=0 denoting the action of the secret weapon, which will decrease the endurance value of the battleships between the X-th and Y-th battleship, inclusive. The T=1 denoting the query of the commander which ask for the sum of the endurance value of the battleship between X-th and Y-th, inclusive.
 
Output
For each test case, print the case number at the first line. Then print one line for each query. And remember follow a blank line after each test case.
 //这有重点 英语不好就是不行啊,题目让在每个测试用例后给出一个空行。。
Sample Input
10 1 2 3 4 5 6 7 8 9 10 5 0 1 10 1 1 10 1 1 5 0 5 8 1 4 8
 

Sample Output
Case #1: 19 7 6
经典的线段树区间更新问题,对于无法直接对根进行更新的题还是从叶子做起吧
#include<stdio.h>
#include<math.h>
#include<string.h>
#include<algorithm>
#define LL long long
#define rson m+1,r,rt<<1|1
#define lson l,m,rt<<1
using namespace std;
const int maxn=100010;
LL tree[maxn*4];
void pushup(int rt){
	tree[rt]=tree[rt<<1]+tree[rt<<1|1];
	return;
}
void build(int l,int r,int rt){
	if(l==r){
		scanf("%I64d",&tree[rt]);
		return;
	}
	int m=(l+r)>>1;
	build(lson);
	build(rson);
	pushup(rt);
} 
void update(int L,int R,int l,int r,int rt){
	if(l==r){
		tree[rt]=sqrt(1.0*tree[rt]);
		return;
		
	}
	int m=(l+r)>>1;
	if(L<=l&&r<=R&&tree[rt]==r-l+1){
		return;
	}
	if(L<=m)
	update(L,R,lson);
	if(m<R)
	update(L,R,rson);
	pushup(rt);
}
LL query(int L,int R,int l,int r,int rt){
	if(L<=l&&R>=r){
		return tree[rt];
	}
	int m=(l+r)>>1;
	LL ans=0;
	if(m>=L)
	ans+=query(L,R,lson);
	if(m<R)
	ans+=query(L,R,rson);
	return ans;
}
int main(){
	int n;
	int test=0;
	while(~scanf("%d",&n)){
		build(1,n,1);
		int k;
		printf("Case #%d:\n", ++test);
		scanf("%d",&k);
		while(k--){
			int a,b,c;
			scanf("%d%d%d",&a,&b,&c);
			if(b>c){
				int t;
				t=b;
				b=c;
				c=t;
			} 
			if(a==1){
				printf("%I64d\n",query(b,c,1,n,1));
			}
			if(a==0){
				update(b,c,1,n,1);
			}
		}
		puts("");
	}
	return 0;
}


posted @ 2017-03-24 21:31  考研小黑  阅读(1)  评论(0编辑  收藏  举报