ignitius and princess 2(全排列)

A - Ignatius and the Princess II

Now our hero finds the door to the BEelzebub feng5166. He opens the door and finds feng5166 is about to kill our pretty Princess. But now the BEelzebub has to beat our hero first. feng5166 says, "I have three question for you, if you can work them out, I will release the Princess, or you will be my dinner, too." Ignatius says confidently, "OK, at last, I will save the Princess." 

"Now I will show you the first problem." feng5166 says, "Given a sequence of number 1 to N, we define that 1,2,3...N-1,N is the smallest sequence among all the sequence which can be composed with number 1 to N(each number can be and should be use only once in this problem). So it's easy to see the second smallest sequence is 1,2,3...N,N-1. Now I will give you two numbers, N and M. You should tell me the Mth smallest sequence which is composed with number 1 to N. It's easy, isn't is? Hahahahaha......" 
Can you help Ignatius to solve this problem? 

InputThe input contains several test cases. Each test case consists of two numbers, N and M(1<=N<=1000, 1<=M<=10000). You may assume that there is always a sequence satisfied the BEelzebub's demand. The input is terminated by the end of file. 
OutputFor each test case, you only have to output the sequence satisfied the BEelzebub's demand. When output a sequence, you should print a space between two numbers, but do not output any spaces after the last number. 
Sample Input

6 4
11 8

Sample Output

1 2 3 5 6 4
1 2 3 4 5 6 7 9 8 11 10

译文:
现在我们的英雄发现了BEelzebub feng5166的大门。他打开门,发现feng5166即将杀死我们美丽的公主。但现在BEelzebub必须首先击败我们的英雄。feng5166说:“我有三个问题要问你,如果你能解决这个问题,我会释放公主,否则你也将成为我的晚餐。” 伊格内修斯自信地说:“好吧,最后,我会拯救公主。” 

“现在我会告诉你第一个问题。” feng5166说:“给定一个从1到N的序列,我们定义1,2,3 ... N-1,N是可以由1到N组成的所有序列中最小的序列(每个数可以在这个问题中只能使用一次)所以很容易看到第二小的序列是1,2,3 ... N,N-1现在我给你两个数字,N和M。告诉我由第1号到第N号组成的第M个最小序列。很容易,不是吗?哈哈哈哈哈......“ 
你能帮助伊格内修斯解决这个问题吗? 
输入输入包含多个测试用例。每个测试案例由两个数字组成,N和M(1 <= N <= 1000,1 <= M <= 10000)。你可能会认为总是有一个序列满足BEelzebub的需求。输入由文件结尾终止。 
产量对于每个测试用例,您只需输出满足BEelzebub需求的序列。输出序列时,应在两个数字之间打印空格,但不要在最后一个数字后面输出任何空格。 
示例输入
6 4
11 8
示例输出
1 2 3 5 6 4
1 2 3 4 5 6 7 9 8 11 10

STL中的algorithm 的全排列应用

复制代码
#include<stdio.h>  
#include<string.h>  
#include<algorithm>  
#define INF 0x3f3f3f3f  
#define ll long long  
#define N 100010  
using namespace std;  
int a[N];  
int main()  
{  
    int n,m;  
    while(scanf("%d%d",&n,&m)!=EOF)  
    {  
        for(int i=1;i<=n;i++)  
            a[i]=i;  
        int k=1;  
        while(next_permutation(a+1,a+n+1))//全排列函数  
        {  
            k++;  
            if(k==m)  
                break;  
        }  
        for(int i=1;i<n;i++)  
            printf("%d ",a[i]);  
        printf("%d\n",a[n]);  
    }  
    return 0;  
} 
复制代码

(上为博客园找的解题代码)

解题的难度在于看不懂题意,没弄懂他需要我求什么,然后就是前段时间对于算法函数algorithm ,数值算法numeric和函数对象functional的理解不够,只是理解了表层的意思,不懂灵活的应用,或者说是没有认真的应用过,经验不足;

复制代码
#include<iostream>
#include<algorithm>
using namespace std;
int main()
{
    int N, M, a[10005];
    while (cin >> N >> M)
    {
        for (int i = 0; i < N; i++)
            a[i] = i + 1;
        int mark = 1;
        while (next_permutation(a,a+N))
        {
            mark++;
            if (mark == M)
                break;
        }
        for (int i = 0; i < N-1; i++)
            cout << a[i] << " ";
        cout << a[N - 1] <<endl;
    }
    return 0;
}
复制代码

(附:经过测试,如果不加控制条件用while一直循环,最后的结束next_permutation是的最后情况)

 

posted @   zzuli风尘  阅读(270)  评论(0编辑  收藏  举报
编辑推荐:
· DeepSeek 解答了困扰我五年的技术问题
· 为什么说在企业级应用开发中,后端往往是效率杀手?
· 用 C# 插值字符串处理器写一个 sscanf
· Java 中堆内存和栈内存上的数据分布和特点
· 开发中对象命名的一点思考
阅读排行:
· DeepSeek 解答了困扰我五年的技术问题。时代确实变了!
· PPT革命!DeepSeek+Kimi=N小时工作5分钟完成?
· What?废柴, 还在本地部署DeepSeek吗?Are you kidding?
· DeepSeek企业级部署实战指南:从服务器选型到Dify私有化落地
· 程序员转型AI:行业分析
点击右上角即可分享
微信分享提示