Bone Collector HDU - 2602

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

Input

 

The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

 

Output

 

One integer per line representing the maximum of the total value (this number will be less than 2 31).

 

Sample Input

1
5 10
1 2 3 4 5
5 4 3 2 1

Sample Output

14

动态规划背包问题,滚动数组优化

#include <bits/stdc++.h>

using namespace std;
struct node{
    int v, m;
}a[1010];
int n, v;
long long int dp[1010];

int main()
{
    int t;
    scanf("%d", &t);
    while(t--){
        scanf("%d%d", &n, &v);
        for(int i = 0; i<n; i++)
            scanf("%d", &a[i].m);
        for(int i = 0; i<n; i++)
            scanf("%d", &a[i].v);
        memset(dp, 0, sizeof(dp));
        for(int i = 0; i<n; i++)
            for(int j = v; j >= a[i].v; j--)
                dp[j] = max(dp[j], dp[j  - a[i].v] + a[i].m);
        printf("%lld\n", dp[v]);
    }
    return 0;
}

 


posted @ 2020-04-02 19:42  方寸之海  阅读(146)  评论(0编辑  收藏  举报