WERTYU题目

 
WERTYU题目

A common typing error is to place your hands on the keyboard one row to the right of the correct position. Then ``Q'' is typed as ``W'' and ``J'' is typed as ``K'' and so on. Your task is to decode a message typed in this manner.

 

Input

Input consists of several lines of text. Each line may contain digits, spaces, uppercase letters (except ``Q'', ``A'', ``Z''), or punctuation shown above [except back-quote (`)]. Keys labeled with words [TabBackSpControl, etc.] are not represented in the input.

 

Output

You are to replace each letter or punctuation symbol by the one immediately to its left on the QWERTY keyboard shown above. Spaces in the input should be echoed in the output.

 

Sample Input

O S, GOMR YPFSU/

 

Sample Output

I AM FINE TODAY.

#include<stdio.h>
#include<string.h>
char str1[]= {'`','1','2','3','4','5','6','7','8','9','0','-','=','Q','W','E','R','T','Y','U','I','I','O','P','[',']','\\','A','S','D','F','G','H','J','K','L',';','\'','Z','X','C','V','B','N','M',',','.','/'};
int main(void) 
{
	char str2[100];
	while(scanf("%s",str2)!=EOF)
	 {
	 	int i,j;
		for(i=0; i<strlen(str2); i++) 
		{
			if(str2[i]==' ')
		    {
		    	printf(" ");
			}
		   else
		   {
		   		for(j=0; j<strlen(str1); j++) 
				{
					if(str2[i]==str1[j])
					{
						printf("%c",str1[j-1]);
						break;
					}
					
				}
		   }	
		}
		printf("\n");
	}
	return 0;
}


posted @ 2017-06-14 20:19  jzdwajue  阅读(149)  评论(0编辑  收藏  举报