poj1753 Flip Game(枚举Enum+dfs)

转载请注明出处:http://blog.csdn.net/u012860063?viewmode=contents

题目链接:http://poj.org/problem?id=1753

----------------------------------------------------------------------------------------------------------------------------------------------------------
欢迎光临天资小屋害羞害羞害羞害羞http://user.qzone.qq.com/593830943/main

----------------------------------------------------------------------------------------------------------------------------------------------------------


Description

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules: 
  1. Choose any one of the 16 pieces. 
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

Consider the following position as an example: 

bwbw 
wwww 
bbwb 
bwwb 
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become: 

bwbw 
bwww 
wwwb 
wwwb 
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal. 

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

4

题意:找出能使4X4的棋盘中的棋子同色的最小步数。


代码例如以下:

#include <iostream>
#include <cstring>
using namespace std;
int chess[7][7];//事实上利用的仅仅有中心的4x4
int x[5] = {0,0,1,0,-1};
int y[5] = {0,1,0,-1,0};
int flag, step;
int judge(int chess[7][7])//推断颜色是否所有同样
{
	for(int i = 1; i <= 4; i++)
	{
		for(int j = 1; j <= 4; j++)
		{
			if(chess[i][j] != chess[1][1])
				return 0;
		}
	}
	return 1;
}
void flip(int row, int col)//翻棋
{
	for(int i = 0; i <= 4; i++)
	{
		if(chess[row+x[i]][col+y[i]] == 1)
			chess[row+x[i]][col+y[i]] = 0;
		else
			chess[row+x[i]][col+y[i]] = 1;
	}
	return;
}
void dfs(int row,int col, int deep)//深搜固定步数看能否同色
{
	if(deep == step)
	{
		flag = judge(chess);
		return;
	}
	if(flag || row == 5)
		return;
	flip(row,col);
	if(col < 4)
		dfs(row,col+1,deep+1);
	else
		dfs(row+1,1,deep+1);
	flip(row,col);//不符合就翻回之前的状态
	if(col < 4)
		dfs(row,col+1,deep);
	else
		dfs(row+1,1,deep);
	return;
}
int main()
{
	char temp;
	int i, j;
	memset(chess,0,sizeof(chess));
	for(i = 1; i <= 4; i++)
	{
		for(j = 1; j <= 4; j++)
		{
			cin >>temp;
			if(temp == 'b')
				chess[i][j] = 1;
		}
	}
	for(step = 0; step <= 16; step++)
	{//对每一步进行枚举(Enum)
		dfs(1,1,0);
		if(flag)
			break;
	}
	if(flag)
		cout<<step<<endl;
	else
		cout<<"Impossible"<<endl;
	return 0;
}


posted @ 2017-05-06 08:22  jzdwajue  阅读(99)  评论(0编辑  收藏  举报