#2017 Multi-University Training Contest - Team 2 1001

problem 1001 Is Derek lying?(大水题)

Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)


Total Submission(s): 0 Accepted Submission(s): 0

Problem Description

Derek and Alfia are good friends.Derek is Chinese,and Alfia is Austrian.This summer holiday,they both participate in the summer camp of Borussia Dortmund.During the summer camp,there will be fan tests at

intervals.The test consists of N choice questions and each question is followed by three choices marked “A” “B” and “C”.Each question has only one correct answer and each question is worth 1 point.It means that

if your answer for this question is right,you can get 1 point.The total score of a person is the sum of marks for all questions.When the test is over,the computer will tell Derek the total score of him and Alfia.Then Alfia

will ask Derek the total score of her and he will tell her: “My total score is X,your total score is Y.”But Derek is naughty,sometimes he may lie to her. Here give you the answer that Derek and Alfia made,you

should judge whether Derek is lying.If there exists a set of standard answer satisfy the total score that Derek said,you can consider he is not lying,otherwise he is lying.

Input

The first line consists of an integer T,represents the number of test cases.


For each test case,there will be three lines.


The first line consists of three integers N,X,Y,the meaning is mentioned above.


The second line consists of N characters,each character is “A” “B” or “C”,which represents the answer of Derek for each question.


The third line consists of N characters,the same form as the second line,which represents the answer of Alfia for each question.

Data Range:1≤N≤80000,0≤X,Y≤N,∑Ti=1N≤300000

Output

For each test case,the output will be only a line.


Please print “Lying” if you can make sure that Derek is lying,otherwise please print “Not lying”.

Sample Input

2


3 1 3


AAA


ABC


5 5 0


ABCBC


ACBCB

Sample Output

Not lying


Lying

题解:

如果我们记录下这两个人相同答案的个数,记为cnt . 那么我们可以发现,他们分数和的可能的最大值为N+CNT(答案相同部分两个人都对,答案不同时有一个人对),如果这两个人的分数和超过了N+CNT,那么就可以


认定他撒谎了.如果较高的分数-较低的分数的差>N-CNT(即分数的差大于他们可能的最大的差),那么久可以认定他撒谎了,否则就是没有撒谎

官方题解:

首先,我们统计出Derek和Alfia答案相同的题目数量k1和答案不同的题目数量k2. 对于两人答案相同的题目,共有以下两种情况:


两人都对


b.两人都错 对于两人答案不同的题目,共有以下三种情况: c.Derek对Alfia错 d.Alfia对Derek错 e.两人都错 于是我们可以列出一些方程: k1+k2=n a+b=k1 c+d+e=k2 a+c=x a+d=y 又a,b,c,d,e均为非负整数,且满足

a,b<=k1;c,d,e<=k2 将a,b,d,e全部用c替换后需要同时满足以下四个条件: 0<=c<=k2 x-y<=c<=k2+x-y (x-y)/2<=c<=(k2+x-y)/2 x-k1<=c<=x 我们只需要判断这四段区间存不存在公共的整数点,

如果存在,则说明Derek没有说谎;如果不存在,则说明Derek在说谎。

Code

#include<bits/stdc++.h>
#define ll long long
using namespace std;
int n,x,y,cnt;
char s1[521666],s2[521666];
int main(){
	int T; scanf("%d",&T);
	while (T--){
		scanf("%d%d%d\n",&n,&x,&y);
		if (x>y) swap(x,y);
		scanf("%s",s1); scanf("%s",s2); cnt = 0;
		for (int i=0; i<n; ++i) if (s1[i]==s2[i]) ++cnt;
		if (x+y-n>cnt){ printf("Lying\n"); continue;}
		if (n-cnt<y-x){ printf("Lying\n"); continue;}
		printf("Not lying\n");
	}
	return 0;
}

posted @ 2017-07-27 15:54  Iamhx  阅读(105)  评论(0编辑  收藏  举报