junior19

  博客园 :: 首页 :: 博问 :: 闪存 :: 新随笔 :: 联系 :: 订阅 订阅 :: 管理 ::

Ignatius and the Princess III

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19924    Accepted Submission(s): 13936


Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:
  N=a[1]+a[2]+a[3]+...+a[m];
  a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
  4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
 

Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
 

Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
 

Sample Input
4 10 20
 

Sample Output
5 42 627
 

Author
Ignatius.L

将一个正整数分成若干个数相加,求分解的方案数。

法一:动态规划:易得dp[i] = dp[i] + dp[i-a[k]], (k<=i)。

# include <stdio.h>
int main()
{
    int n, i, j, dp[125]={1};
    for(i=1; i<=120; ++i)
        for(j=i; j<=120; ++j)
            dp[j] += dp[j-i];
    while(~scanf("%d",&n))
        printf("%d\n",dp[n]);
    return 0;
}

法二:母函数:

# include <stdio.h>
# define MAXN 120
int a[MAXN+3]={1}, b[MAXN+3]={0};
void init()
{
    int i, j, k;
    for(i=1; i<=MAXN; ++i)//枚举分解的数
    {
        for(j=0; j<=MAXN; j+=i)//从0开始,步长为i
            for(k=0; j+k<=MAXN; ++k)
                b[j+k] += a[k];//多项式的系数相加
        for(j=0; j<=MAXN; ++j)
        {
            a[j] = b[j];//更新a数组
            b[j] = 0;//清除b数组
        }
    }
}
int main()
{
    init();
    int n;
    while(~scanf("%d",&n))
        printf("%d\n",a[n]);
    return 0;
}




posted on 2017-01-23 14:38  junior19  阅读(134)  评论(0编辑  收藏  举报