junior19

  博客园 :: 首页 :: 博问 :: 闪存 :: 新随笔 :: 联系 :: 订阅 订阅 :: 管理 ::

Round Numbers
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 12712   Accepted: 4892

Description

The cows, as you know, have no fingers or thumbs and thus are unable to play Scissors, Paper, Stone' (also known as 'Rock, Paper, Scissors', 'Ro, Sham, Bo', and a host of other names) in order to make arbitrary decisions such as who gets to be milked first. They can't even flip a coin because it's so hard to toss using hooves.

They have thus resorted to "round number" matching. The first cow picks an integer less than two billion. The second cow does the same. If the numbers are both "round numbers", the first cow wins,
otherwise the second cow wins.

A positive integer N is said to be a "round number" if the binary representation of N has as many or more zeroes than it has ones. For example, the integer 9, when written in binary form, is 1001. 1001 has two zeroes and two ones; thus, 9 is a round number. The integer 26 is 11010 in binary; since it has two zeroes and three ones, it is not a round number.

Obviously, it takes cows a while to convert numbers to binary, so the winner takes a while to determine. Bessie wants to cheat and thinks she can do that if she knows how many "round numbers" are in a given range.

Help her by writing a program that tells how many round numbers appear in the inclusive range given by the input (1 ≤ Start < Finish ≤ 2,000,000,000).

Input

Line 1: Two space-separated integers, respectively Start and Finish.

Output

Line 1: A single integer that is the count of round numbers in the inclusive range Start..Finish

Sample Input

2 12

Sample Output

6

Source

题意:计算范围内数的二进制中0的数目大于等于1的数目的个数。

# include <stdio.h>
# include <string.h>
int a[33], dp[33][66];
int dfs(int pos, int icount, bool pre, bool limit)//pos代表数位,icount表示0和1数目,pre判断前导0,limit判断上界。
{
    if(pos==-1) return icount<=32;
    if(!limit && !pre && dp[pos][icount] != -1) return dp[pos][icount];
    int up = limit?a[pos]:1;
    int tmp = 0;
    for(int i=0; i<=up; ++i)
    {
        if(pre&&!i)
            tmp += dfs(pos-1, icount, true, limit&&i==a[pos]);
        else
            tmp += dfs(pos-1, i?icount+1:icount-1, false, limit&&i==a[pos]);
    }
    if(!limit && !pre) dp[pos][icount] = tmp;
    return tmp;
}
int solve(int num)
{
    int pos = 0;
    while(num)
    {
        a[pos++] = num&1;
        num>>=1;
    }
    return dfs(pos-1, 32, true, true);
}
int main()
{
    memset(dp, -1, sizeof(dp));
    int n, m;
    while(~scanf("%d%d",&n,&m))
        printf("%d\n",solve(m)-solve(n-1));
    return 0;
}



posted on 2017-01-29 12:40  junior19  阅读(139)  评论(0编辑  收藏  举报