junior19

  博客园 :: 首页 :: 博问 :: 闪存 :: 新随笔 :: 联系 :: 订阅 订阅 :: 管理 ::

Corn Fields
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 14098   Accepted: 7396

Description

Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

Input

Line 1: Two space-separated integers: M and N 
Lines 2..M+1: Line i+1 describes row i of the pasture with N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)

Output

Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.

Sample Input

2 3
1 1 1
0 1 0

Sample Output

9

Hint

Number the squares as follows:
1 2 3
  4  

There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.

Source


dp[i][j]表示第i行的第j种布局有多少种。dp[i][j] += dp[i-1][t],t∈[0, 1<<m),其中j布局要符合第i行地形,t布局要符合第i-1行的地形,j布局与t布局又合法(没有上下相邻的1)

# include <stdio.h>
# include <string.h>
# define MOD 100000000
int map[13], val[1<<13], dp[13][1<<13];
bool judge(int i, int j) {return i&j;}
int main()
{
    int k, m, n, tmp, sum;
    while(~scanf("%d%d",&n,&m))
    {
        memset(map, 0, sizeof(map));
        memset(dp, 0, sizeof(dp));
        for(int i=1; i<=n; ++i)
            for(int j=1; j<=m; ++j)
            {
                scanf("%d",&tmp);
                if(!tmp)
                    map[i] |= 1<<(j-1);//模拟地形布局
            }
        int up = 1<<m;
        sum = k = 0;
        for(int i=0; i<up; ++i)
            if(!judge(i, i<<1))
                val[k++] = i;//存储所有可能的合法布局
        for(int i=0; i<k; ++i)
            if(!judge(map[1], val[i]))//由于map将贫瘠地存为1,此处判断该布局有无与贫瘠地重合
                dp[1][i] = 1; //无重合就记为1种方案
        for(int i=2; i<=n; ++i)
            for(int j=0; j<k; ++j)
                if(!judge(map[i], val[j]))
                    for(int t=0; t<k; ++t)
                        if(dp[i-1][t] && !judge(val[t], val[j]))
                            dp[i][j] += dp[i-1][t];
        for(int i=0; i<k; ++i)
            sum = (sum + dp[n][i]) % MOD;
        printf("%d\n",sum);
    }
    return 0;
}


posted on 2017-01-30 10:52  junior19  阅读(111)  评论(0编辑  收藏  举报