junior19

  博客园 :: 首页 :: 博问 :: 闪存 :: 新随笔 :: 联系 :: 订阅 订阅 :: 管理 ::

detail:http://blog.csdn.net/lvshubao1314/article/details/41624239

Triangular Pastures
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 7802   Accepted: 2590

Description

Like everyone, cows enjoy variety. Their current fancy is new shapes for pastures. The old rectangular shapes are out of favor; new geometries are the favorite. 

I. M. Hei, the lead cow pasture architect, is in charge of creating a triangular pasture surrounded by nice white fence rails. She is supplied with N (3 <= N <= 40) fence segments (each of integer length Li (1 <= Li <= 40) and must arrange them into a triangular pasture with the largest grazing area. Ms. Hei must use all the rails to create three sides of non-zero length. 

Help Ms. Hei convince the rest of the herd that plenty of grazing land will be available.Calculate the largest area that may be enclosed with a supplied set of fence segments. 

Input

* Line 1: A single integer N 

* Lines 2..N+1: N lines, each with a single integer representing one fence segment's length. The lengths are not necessarily unique. 

Output

A single line with the integer that is the truncated integer representation of the largest possible enclosed area multiplied by 100. Output -1 if no triangle of positive area may be constructed. 

Sample Input

5
1
1
3
3
4

Sample Output

692

Hint

[which is 100x the area of an equilateral triangle with side length 4] 

Source


题意:给定N条木棒,求用完这些木棒能拼成的三角形面积最大值。

思路:范围只有40,可以先枚举所有情况,dp[i][j]表示含有i和j两条边的三角形,类似01背包:dp[i][j] = (dp[i][j-a[k]] || dp[i-a[k]][j])?1:0。

# include <stdio.h>
# include <math.h>
# include <string.h>
# include <algorithm>
using namespace std;
int dp[801][801], a[41];
int main()
{
    int n, sum, half;
    while(~scanf("%d",&n))
    {
        sum = 0;
        for(int i=0; i<n; ++i)
        {
            scanf("%d",&a[i]);
            sum += a[i];
        }
        half = sum >> 1;//优化:三角形边长小于等于周长一半。
        memset(dp, 0, sizeof(dp));
        dp[0][0] = 1;
        for(int i=0; i<n; ++i)
            for(int j=half; j>=0; --j)
                for(int k=j; k>=0; --k)//优化:k等于j即可,因为dp[2][3]与dp[3][2]这种情况不必重复。
                    if(j>=a[i]&&dp[j-a[i]][k] || k>=a[i]&&dp[j][k-a[i]])
                        dp[j][k] = 1;
        int imax = -1;
        for(int i=half; i>=1; --i)
            for(int j=i; j>=1; --j)
            {
                if(dp[i][j])
                {
                    int k = sum - i - j;
                    if(i+j>k && i+k>j && j+k>i)
                    {
                        double tmp = (i+j+k)*1.0/2;
                        int area = int(sqrt(tmp*(tmp-i)*(tmp-j)*(tmp-k))*100);//海伦公式
                        imax = max(imax, area);
                    }
                }
            }
        printf("%d\n",imax);
    }
    return 0;
}



posted on 2017-02-01 16:54  junior19  阅读(218)  评论(0编辑  收藏  举报