junior19

  博客园 :: 首页 :: 博问 :: 闪存 :: 新随笔 :: 联系 :: 订阅 订阅 :: 管理 ::

4 Values whose Sum is 0
Time Limit: 15000MS   Memory Limit: 228000K
Total Submissions: 20863   Accepted: 6282
Case Time Limit: 5000MS

Description

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .

Input

The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 228 ) that belong respectively to A, B, C and D .

Output

For each input file, your program has to write the number quadruplets whose sum is zero.

Sample Input

6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45

Sample Output

5

Hint

Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).

Source


题意:从4列数据每列选1个使之和为0,求可挑选的方案总数。

思路:将第1,2列和第3,4列的和全部求出来,排序,然后二分直至找到和为0。

# include <stdio.h>
# include <algorithm>
# define MAXN 4000
using namespace std;
int a[MAXN][4], b[MAXN*MAXN], c[MAXN*MAXN];
int main()
{
    int n, l, r, sum, tmp, cnt;
    while(~scanf("%d",&n))
    {
        sum = cnt = 0;
        for(int i=0; i<n; ++i)
            scanf("%d%d%d%d",&a[i][0],&a[i][1],&a[i][2],&a[i][3]);
        for(int i=0; i<n; ++i)
            for(int j=0; j<n; ++j)
            {
                b[cnt] = a[i][0] + a[j][1];
                c[cnt++] = a[i][2] + a[j][3];
            }
        sort(b, b+cnt);
        sort(c, c+cnt);
        for(int i=0; i<cnt; ++i)
        {
            tmp = 0;
            l = 0;
            r = cnt-1;
            while(l<r)
            {
                int mid = (l+r)>>1;
                if(b[i]+c[mid]<0)
                    l = mid + 1;
                else
                    r = mid;
            }
            if(r==0&&(b[i]+c[r]!=0) || l==cnt-1&&(b[i]+c[r]!=0))continue;
            if(b[i]+c[r]==0) ++tmp;
            for(int k=r-1; k>=0&&(b[i]+c[k])==0; --k) ++tmp;//符合情况的c[r]可能扎堆在一起,向前搜索。
            for(int k=r+1; k<cnt&&(b[i]+c[k])==0; ++k) ++tmp;//向后搜索。
            sum += tmp;
            for(;i+1<cnt&&b[i]==b[i+1]; ++i) sum += tmp;//计算相同的b[i]。
        }
        printf("%d\n",sum);
    }
    return 0;
}


posted on 2017-02-02 00:21  junior19  阅读(113)  评论(0编辑  收藏  举报