junior19

  博客园 :: 首页 :: 博问 :: 闪存 :: 新随笔 :: 联系 :: 订阅 订阅 :: 管理 ::

Cup

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8215    Accepted Submission(s): 2504


Problem Description
The WHU ACM Team has a big cup, with which every member drinks water. Now, we know the volume of the water in the cup, can you tell us it height? 

The radius of the cup's top and bottom circle is known, the cup's height is also known.
 

Input
The input consists of several test cases. The first line of input contains an integer T, indicating the num of test cases.
Each test case is on a single line, and it consists of four floating point numbers: r, R, H, V, representing the bottom radius, the top radius, the height and the volume of the hot water.

Technical Specification

1. T ≤ 20.
2. 1 ≤ r, R, H ≤ 100; 0 ≤ V ≤ 1000,000,000.
3. r ≤ R.
4. r, R, H, V are separated by ONE whitespace.
5. There is NO empty line between two neighboring cases.

 

Output
For each test case, output the height of hot water on a single line. Please round it to six fractional digits.
 

Sample Input
1 100 100 100 3141562
 

Sample Output
99.999024
 

Source
 

题意:给定一个杯的底半径,口半径,高度,水的体积,求水的高度。

思路:水的高度一定介于0到杯子的高度,此范围内二分即可,圆台体积:v = π/3*h*(R*R + r*r + R*r),根据三角函数易有tanθ = H/(R-r) = h/(R'-r)。此题水的体积可能大于杯的体积,这时应处理结果为杯的高度,否则可能超时。

# include <stdio.h>
# include <math.h>
# define pi acos(-1.0)
double r, R, H, v, left, right, mid, V;
double fun(double h)
{
    double R1 = (R-r)*h/H + r;
    return pi/3*h*(R1*R1+r*r+R1*r);
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lf%lf%lf%lf",&r,&R,&H,&v);
        V = pi/3*H*(R*R+r*r+R*r);
        left = 0;
        right = H;
        mid = (left+right)/2;
        int tmp;
        while(fabs(fun(mid)-v)>1e-8 && fabs(fun(mid)-V)>1e-8)
        {
            if(fun(mid)<v)
                left = mid;
            else
                right = mid;
            mid = (left+right)/2;
        }
        printf("%.6f\n",mid);
    }
    return 0;
}




posted on 2017-02-03 00:45  junior19  阅读(134)  评论(0编辑  收藏  举报