junior19

  博客园 :: 首页 :: 博问 :: 闪存 :: 新随笔 :: 联系 :: 订阅 订阅 :: 管理 ::

reference:http://blog.csdn.net/liverpippta/article/details/7746029

Prime Distance
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 17616   Accepted: 4729

Description

The branch of mathematics called number theory is about properties of numbers. One of the areas that has captured the interest of number theoreticians for thousands of years is the question of primality. A prime number is a number that is has no proper factors (it is only evenly divisible by 1 and itself). The first prime numbers are 2,3,5,7 but they quickly become less frequent. One of the interesting questions is how dense they are in various ranges. Adjacent primes are two numbers that are both primes, but there are no other prime numbers between the adjacent primes. For example, 2,3 are the only adjacent primes that are also adjacent numbers. 
Your program is given 2 numbers: L and U (1<=L< U<=2,147,483,647), and you are to find the two adjacent primes C1 and C2 (L<=C1< C2<=U) that are closest (i.e. C2-C1 is the minimum). If there are other pairs that are the same distance apart, use the first pair. You are also to find the two adjacent primes D1 and D2 (L<=D1< D2<=U) where D1 and D2 are as distant from each other as possible (again choosing the first pair if there is a tie).

Input

Each line of input will contain two positive integers, L and U, with L < U. The difference between L and U will not exceed 1,000,000.

Output

For each L and U, the output will either be the statement that there are no adjacent primes (because there are less than two primes between the two given numbers) or a line giving the two pairs of adjacent primes.

Sample Input

2 17
14 17

Sample Output

2,3 are closest, 7,11 are most distant.
There are no adjacent primes.

Source

题意:找出区间内相邻的最近和最远的两对素数。

思路:区间在int范围内太大,只需打出sqrt(2147483647)以内的素数即可,然后利用打出的素数将所求区间的素数表向左偏移,最后容易找出距离最近和最远的相邻素数。

# include <stdio.h>
# include <string.h>
# define MAXN 50000
# define INF  0x3f3f3f3f
int a[1000001]={0}, p[MAXN+1]={0}, q[MAXN+1]={0};
int main()
{
    int cnt=0, l, r, dis, res1, res2, imax, imin;
    for(int i=2; i<=MAXN; ++i)
        if(!q[i])
        {
            p[cnt++] = i;
            for(int j=i+i; j<=MAXN; j+=i)
                q[j] = 1;
        }
    while(~scanf("%d%d",&l,&r))
    {
        imin = INF;
        imax = -INF;
        memset(a, 0, sizeof(a));
        if(l==1) l=2;//1要特别处理
        for(int i=0; i<cnt; ++i)
        {
            int x = (l-1)/p[i] + 1;
            int y = r/p[i];
            for(int j=x; j<=y; ++j)
                if(j>1)//!
                    a[j*p[i]-l] = 1;//向左偏移
        }
        int k = -1;
        for(int i=0; i<=r-l; ++i)
        {
            if(!a[i])
            {
                if(k == -1)
                {
                    k = i;
                    continue;
                }
                dis = i - k;
                if(dis > imax)
                {
                    res1 = i+l;
                    imax = dis;
                }
                if(dis < imin)
                {
                    res2 = i+l;
                    imin = dis;
                }
                k = i;
            }
        }
        if(imax < 0)
            puts("There are no adjacent primes.");
        else
            printf("%d,%d are closest, %d,%d are most distant.\n",res2-imin, res2, res1-imax, res1);
    }
    return 0;
}


posted on 2017-02-03 21:06  junior19  阅读(102)  评论(0编辑  收藏  举报