junior19

  博客园 :: 首页 :: 博问 :: 闪存 :: 新随笔 :: 联系 :: 订阅 订阅 :: 管理 ::

The Balance

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7799    Accepted Submission(s): 3230


Problem Description
Now you are asked to measure a dose of medicine with a balance and a number of weights. Certainly it is not always achievable. So you should find out the qualities which cannot be measured from the range [1,S]. S is the total quality of all the weights.
 

Input
The input consists of multiple test cases, and each case begins with a single positive integer N (1<=N<=100) on a line by itself indicating the number of weights you have. Followed by N integers Ai (1<=i<=N), indicating the quality of each weight where 1<=Ai<=100.
 

Output
For each input set, you should first print a line specifying the number of qualities which cannot be measured. Then print another line which consists all the irrealizable qualities if the number is not zero.
 

Sample Input
3 1 2 4 3 9 2 1
 

Sample Output
0 2 4 5
 

Source
题意:给出N个砝码,总重量和为M,求出1~M中不能通过砝码称出的重量。

思路:略。

背包做法:

# include <stdio.h>
# include <stdlib.h>
# include <string.h>
int main()
{
    int dp[2][10101], a[101], b[101];
    int n, sum;
    while(~scanf("%d",&n))
    {
        sum = 0;
        memset(dp, 0, sizeof(dp));
        for(int i=0; i<n; ++i)
        {
            scanf("%d",&a[i]);
            sum += a[i];
        }
        dp[0][0] = dp[1][0]= 1;
        int t=1;
        for(int i=0; i<n; ++i)
        {
            for(int j=sum; j>=0; --j)
            {
                dp[t][j] = dp[1-t][j];
                if(dp[1-t][abs(j-a[i])] || dp[1-t][j+a[i]]) dp[t][j] = 1;
            }
            t = 1-t;
            memset(dp[t], 0, sizeof(dp[t]));
        }
        t = 1-t;
        int cnt = 0;
        for(int i=1; i<=sum; ++i)
            if(!dp[t][i])
                b[cnt++] = i;
        printf("%d\n",cnt);
        if(cnt)
        {
            for(int i=0; i<cnt-1; ++i)
                printf("%d ",b[i]);
            printf("%d\n",b[cnt-1]);
        }
    }
    return 0;
}

母函数做法:

# include <stdio.h>
# include <string.h>
# include <stdlib.h>
int main()
{
    int a[101], n, sum, b[10101], c[10101];
    while(~scanf("%d",&n))
    {
        memset(b, 0, sizeof(b));
        memset(c, 0, sizeof(c));
        b[0] = 1;
        sum = 0;
        for(int i=0; i<n; ++i)
        {
            scanf("%d",&a[i]);
            sum += a[i];
        }
        for(int i=0; i<n; ++i)
        {
            for(int k=0; k<=a[i]; k+=a[i])
            {
                for(int j=0; j+k<=sum; ++j)
                {
                    if(b[j])
                    {
                        c[j+k] = 1;
                        c[abs(j-k)] = 1;
                    }
                }
            }
            for(int j=0; j<=sum; ++j)
            {
                b[j] = c[j];
                c[j] = 0;
            }
        }
        int cnt = 0;
        for(int i=1; i<=sum; ++i)
            if(!b[i])
                c[cnt++] = i;
        printf("%d\n",cnt);
        if(cnt)
        {
            for(int i=0; i<cnt-1; ++i)
                printf("%d ",c[i]);
            printf("%d\n",c[cnt-1]);
        }

    }
    return 0;
}




posted on 2017-02-05 21:04  junior19  阅读(133)  评论(0编辑  收藏  举报