junior19

  博客园 :: 首页 :: 博问 :: 闪存 :: 新随笔 :: 联系 :: 订阅 订阅 :: 管理 ::

还是畅通工程

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 42701    Accepted Submission(s): 19454


Problem Description
某省调查乡村交通状况,得到的统计表中列出了任意两村庄间的距离。省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可),并要求铺设的公路总长度为最小。请计算最小的公路总长度。
 

Input
测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( < 100 );随后的N(N-1)/2行对应村庄间的距离,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间的距离。为简单起见,村庄从1到N编号。
当N为0时,输入结束,该用例不被处理。
 

Output
对每个测试用例,在1行里输出最小的公路总长度。
 

Sample Input
3 1 2 1 1 3 2 2 3 4 4 1 2 1 1 3 4 1 4 1 2 3 3 2 4 2 3 4 5 0
 

Sample Output
3 5
Hint
Hint
Huge input, scanf is recommended.
 

Source

# include <stdio.h>
# include <algorithm>
using namespace std;

struct node
{
    int a, b, c;
}nod[5000];

bool cmp(node a, node b)//贪心,将短的路放前面。
{
    return a.c < b.c;
}

int pre[101];
int find(int x)
{
    if(x != pre[x])
        pre[x] = find(pre[x]);//压缩路径,降低树的高度。
    return pre[x];
}
int main()
{
    int n;
    while(~scanf("%d",&n),n)
    {
        int ans = n-1, sum=0;//n条村至少要n-1条路。
        for(int i=1; i<=n; ++i)
            pre[i] = i;
        for(int i=0; i<n*(n-1)/2; ++i)
            scanf("%d%d%d",&nod[i].a,&nod[i].b,&nod[i].c);
        sort(nod, nod+n*(n-1)/2, cmp);
        for(int i=0; i<n*(n-1)/2; ++i)
        {
            int px = find(nod[i].a);
            int py = find(nod[i].b);
            if(px != py)
            {
                --ans;
                sum += nod[i].c;
                pre[px] = py;
                if(ans == 0)
                    break;
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}


posted on 2017-02-11 13:27  junior19  阅读(137)  评论(0编辑  收藏  举报