junior19

  博客园 :: 首页 :: 博问 :: 闪存 :: 新随笔 :: 联系 :: 订阅 订阅 :: 管理 ::

Is It A Tree?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 23034    Accepted Submission(s): 5267


Problem Description
A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties. 
There is exactly one node, called the root, to which no directed edges point. 

Every node except the root has exactly one edge pointing to it. 

There is a unique sequence of directed edges from the root to each node. 

For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.



In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not. 

 

Input
The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero. 
 

Output
For each test case display the line ``Case k is a tree." or the line ``Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1). 
 

Sample Input
6 8 5 3 5 2 6 4 5 6 0 0 8 1 7 3 6 2 8 9 7 5 7 4 7 8 7 6 0 0 3 8 6 8 6 4 5 3 5 6 5 2 0 0 -1 -1
 

Sample Output
Case 1 is a tree. Case 2 is a tree. Case 3 is not a tree.
 

Source
思路:不合法的情况①某节点父节点多于一个,②存在环,③树根节点多于一个。

输入负数结束程序

# include <stdio.h>
# include <string.h>
int pre[1001], vis[1001], kind[1001], flag, n, road;//vis记录哪些点已经有父节点,kind记录点的种数。

void init()
{
    flag = 1;
    n = road = 0;
    for(int i=0; i<=1000; ++i)
        pre[i] = i;
    memset(kind, 0, sizeof(kind));
    memset(vis, 0, sizeof(vis));
}
int find(int x)
{
    if(x != pre[x])
        pre[x] = find(pre[x]);
    return pre[x];
}
int main()
{
    init();
    int x, y, cas=1;
    while(1)
    {
        scanf("%d%d",&x,&y);
        if(x < 0 && y < 0)
            break;
        if(x && y)
        {
            if(flag)
            {
                if(!vis[y])
                    vis[y] = 1;
                else
                    flag = 0;
                if(!kind[x])
                {
                    kind[x] = 1;
                    ++n;
                }
                if(!kind[y])
                {
                    kind[y] = 1;
                    ++n;
                }
                int px = find(x);
                int py = find(y);
                if(px != py)
                {
                    ++road;
                    pre[px] = py;
                }
                else
                    flag = 0;
            }

        }
        else
        {
            if(flag && n-1==road || n==0)
                printf("Case %d is a tree.\n",cas++);
            else
                printf("Case %d is not a tree.\n",cas++);
            init();
        }
    }
    return 0;
}



posted on 2017-02-11 18:01  junior19  阅读(120)  评论(0编辑  收藏  举报