junior19

  博客园 :: 首页 :: 博问 :: 闪存 :: 新随笔 :: 联系 :: 订阅 订阅 :: 管理 ::

A Bug's Life

Time Limit: 15000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 14445    Accepted Submission(s): 4709


Problem Description
Background 
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs. 

Problem 
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.
 

Input
The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.
 

Output
The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.
 

Sample Input
2 3 3 1 2 2 3 1 3 4 2 1 2 3 4
 

Sample Output
Scenario #1: Suspicious bugs found! Scenario #2: No suspicious bugs found!
Hint
Huge input,scanf is recommended.
 

Source
题意:n个昆虫,m个恋爱关系,判断有无同性恋昆虫。

思路:种类并查集,sta[i] = 0表示i与父节点是同性,1表示异性,主要思考路径压缩和集合合并的公式。

# include <stdio.h>
# include <string.h>
int pre[2001], sta[2001];

void init(int n)
{
    for(int i=1; i<=n; ++i)
    {
        pre[i] = i;
        sta[i] = 0;
    }
}

int find(int x)
{
    if(x == pre[x])
        return x;
    else
    {
        int t = pre[x];
        pre[x] = find(pre[x]);
        sta[x] = (sta[x] + sta[t])&1;//保证直代和隔代都适用。
        return pre[x];
    }
}
int main()
{
    int t, a, b, n, m, cas=1;
    scanf("%d",&t);
    while(t--)
    {
        bool flag = false;
        scanf("%d%d",&n,&m);
        init(n);
        while(m--)
        {
            scanf("%d%d",&a,&b);
            if(flag)
                continue;
            int px = find(a);
            int py = find(b);
            if(px != py)
            {
                pre[px] = py;
                sta[px] = (sta[a] + sta[b] + 1)&1;//保证0,0; 0,1; 1,0; 1,1四种情况都适用。
            }
            else
                if(sta[a] == sta[b])
                    flag = true;
        }
        if(flag)
            printf("Scenario #%d:\nSuspicious bugs found!\n\n",cas++);
        else
            printf("Scenario #%d:\nNo suspicious bugs found!\n\n",cas++);
    }
    return 0;
}



posted on 2017-02-18 21:17  junior19  阅读(106)  评论(0编辑  收藏  举报