junior19

  博客园 :: 首页 :: 博问 :: 闪存 :: 新随笔 :: 联系 :: 订阅 订阅 :: 管理 ::

Stripies
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 16507   Accepted: 7502

Description

Our chemical biologists have invented a new very useful form of life called stripies (in fact, they were first called in Russian - polosatiki, but the scientists had to invent an English name to apply for an international patent). The stripies are transparent amorphous amebiform creatures that live in flat colonies in a jelly-like nutrient medium. Most of the time the stripies are moving. When two of them collide a new stripie appears instead of them. Long observations made by our scientists enabled them to establish that the weight of the new stripie isn't equal to the sum of weights of two disappeared stripies that collided; nevertheless, they soon learned that when two stripies of weights m1 and m2 collide the weight of resulting stripie equals to 2*sqrt(m1*m2). Our chemical biologists are very anxious to know to what limits can decrease the total weight of a given colony of stripies. 
You are to write a program that will help them to answer this question. You may assume that 3 or more stipies never collide together. 

Input

The first line of the input contains one integer N (1 <= N <= 100) - the number of stripies in a colony. Each of next N lines contains one integer ranging from 1 to 10000 - the weight of the corresponding stripie.

Output

The output must contain one line with the minimal possible total weight of colony with the accuracy of three decimal digits after the point.

Sample Input

3
72
30
50

Sample Output

120.000

Source

Northeastern Europe 2001, Northern Subregion
题意:给定N个数,多次操作将任意两个数a,b变成2*sqrt(a*b),直至剩下一个数,求这个数的最小值。

思路:每次选最大的两个数操作即可,用STL的优先队列比较方便实现。

# include <iostream>
# include <cmath>
# include <cstdio>
# include <queue>
using namespace std;
int main()
{
    int n;
    double tmp, a, b;
    while(~scanf("%d",&n))
    {
        priority_queue<double>Q;
        while(n--)
        {
            scanf("%lf",&tmp);
            Q.push(tmp);
        }
        while(Q.size() != 1)
        {
            a = Q.top();
            Q.pop();
            b = Q.top();
            Q.pop();
            tmp = 2*sqrt(a*b);
            Q.push(tmp);
        }
        printf("%.3f\n",Q.top());
    }
    return 0;
}



posted on 2017-02-19 15:29  junior19  阅读(145)  评论(0编辑  收藏  举报